Navigation using move_base with RGBDSLAMv2 instead of a known map

asked 2018-01-10 08:06:51 -0500

Feng gravatar image

Hey, everyone,

I met some trouble while trying to use move_base package to control my car. But the tutorials of the move_base package is using a known map. I think the move_base package can work using rgbdslamv2 instead of a known map. But I don't know how to do to connect them together. Since the source from google is mostly on laser scan, so i hope i can get some help from you. Thank you very much!

Here is my config files:


enter cTrajectoryPlannerROS:
  max_vel_x: 0.45
  min_vel_x: 0.1
  max_vel_theta: 1.0
  min_in_place_vel_theta: 0.4

  acc_lim_theta: 3.2
  acc_lim_x: 2.5
  acc_lim_y: 2.5

  holonomic_robot: true


obstacle_range: 2.0
raytrace_range: 3.0
#footprint: [[0, 0]]
robot_radius: 0.09
inflation_radius: 0.20

observation_sources: point_cloud_sensor

point_cloud_sensor: {sensor_frame: base_camera, data_type: PointCloud, topic: camera/depth_registered/points, marking: true, clearing: true}


  global_frame: /map
  robot_base_frame: /base_link
  update_frequency: 5.0
  publish_frequency: 5.0
  static_map: false
  rolling_window: true



      global_frame: odom
      robot_base_frame: base_link
      update_frequency: 5.0
      publish_frequency: 2.0
      static_map: false
      rolling_window: true
      width: 3.0
      height: 3.0
      resolution: 0.02


  <master auto="start"/>

  <!-- Run the map server -->
  <node name="map_server" pkg="map_server" type="map_server" args="$(find rgbdslam)/my_map.pgm my_map_resolution"/>

  <!--- Run AMCL -->

  <include file="$(find amcl)/examples/amcl_diff.launch" />

  <node pkg="move_base" type="move_base" respawn="false" name="move_base" output="screen">   
    <rosparam file="$(find AutoCar_2dnav)/costmap_common_params.yaml" command="load" ns="global_costmap" />
    <rosparam file="$(find AutoCar_2dnav)/costmap_common_params.yaml" command="load" ns="local_costmap" />
    <rosparam file="$(find AutoCar_2dnav)/local_costmap_params.yaml" command="load" />
    <rosparam file="$(find AutoCar_2dnav)/global_costmap_params.yaml" command="load" />
    <rosparam file="$(find AutoCar_2dnav)/base_local_planner_params.yaml" command="load" />

How should I change the config files to navigate without a known map? If anyone of you knows a trick to use move_base without map, or sees any error in my config files, any help would be appreciated.

Thank you in advance for your help!

And I m using RGBDSLAMv2 with realsense r200 depth camera. If you need the information of them, I would like to share them to you.

edit retag flag offensive close merge delete


Hi Feng, have you been fortunate with resolving this issue?

Dox gravatar image Dox  ( 2018-04-02 14:30:57 -0500 )edit

Any progress? I have a similar issue

skynet gravatar image skynet  ( 2018-04-17 09:14:20 -0500 )edit

@skynet I am using RTABMap instead RGBDSLAM, and in my global_costmap_params.yaml and local_costmap_params.yaml I set static_map: false same as OP did. I think that should be crucial.

Dox gravatar image Dox  ( 2018-04-17 10:50:25 -0500 )edit