Ask Your Question
0

Cannot get Kinect V1 and ROS Kinetic / Ubuntu 16.04 to output topics

asked 2018-01-09 13:37:11 -0500

Wireline gravatar image

updated 2018-01-10 03:08:40 -0500

Hi

Edit: See self- reply for semi-successful update, though I still cannot get a pointcloud topic publishing (just depthcloud)

I have been trying for 8.5 hours today to try and get my kinect v1 to output a depth pointcloud to RVIZ as per the ROS tutorial. I found the ROS kinect setup instructions tough to follow, so initially I made the install by following this reddit guide.

Thereafter I could get the kinect to work by cd'ing to the openni directory it created, and using the samples to view image and depth data. However once out of the directory and entering roslaunch openni_launch openni.launch, though it would run openni with no error messages, no topics would publish, except static_tf, rosout and rosout_agg). I was unable to bring up the depth camera points topic in rviz and the topics selector under PointCloud2, when added to rviz, was empty. When trying to run rosrun image_view image_view image:=/camera/rgb/image_color, a window would appear and immediately crash.

Then I tried using freenect1 and got the additional topics of: /camera/depth_rectify_depth/parameter_descriptions and /camera/depth_rectify_depth/parameter_updates by using variations on the command roslaunch freenect_launch freenect.launch.

rosrun image_view image_view image:=/camera/rgb/image_color would still crash (consistent issue across all attempts).

I tried editing the openni launch file to add in the device ID in place of the default '#1', no dice.

Eventually I tore everything out and went back to try and work through the ROS Wiki instructions. It says something about using rgbd.launch as of hydro, but the instructions still appear to require the installation of openni nonetheless. Eventually I tried to reinstall following this page http://wiki.ros.org/openni_camera but despite following the line of advice that says

... after you have installed the OpenNI, and be ready to clone the git files for SensorKinect,DO NOT change directory!Otherwise you cannot generate the Redist directory for installation of SensorKinect

The Redist folder still would not generate. Its not clear which folder you should actually be in and I tried a fair few, to no result.

I also tried good old sudo apt-get install ros-kinetic-openni-camera ros-kinetic-openni-launch. Nada.

So after a day of trying to make it work and scouring google, I am completely stumped. No error messages, but no topics either :(

Does the Kinect V1 actually work still with Ubuntu 16.04 and Kinetic? Or has something changed? Is there a current up to date ROS approved one-pager with the process detailed?


Edit: Update:

Intermittently, I can get roslaunch freenect_launch freenect.launch device_id:={serial number} to give me more topics, though this does not include point cloud (camera/depth/points):

/camera/depth/camera_info
/camera/depth/image_raw
/camera/depth/image_raw/compressed
/camera/depth/image_raw/compressed/parameter_descriptions
/camera/depth/image_raw/compressed/parameter_updates
/camera/depth/image_raw/compressedDepth
/camera/depth/image_raw/compressedDepth/parameter_descriptions
/camera/depth/image_raw/compressedDepth/parameter_updates
/camera/depth/image_raw/theora
/camera/depth/image_raw/theora/parameter_descriptions
/camera/depth/image_raw/theora/parameter_updates
/camera/depth_registered/camera_info
/camera/depth_registered/image_raw
/camera/depth_registered ... (more)

edit retag flag offensive close merge delete

Comments

1

Please do not use answers to provide updates. Only post one if/when you're really answering your own question.

Seeing questions with answers tends to discourage other members from posting, so it's best not to do that.

gvdhoorn gravatar imagegvdhoorn ( 2018-01-10 02:33:15 -0500 )edit

1 Answer

Sort by ยป oldest newest most voted
1

answered 2018-01-13 18:37:42 -0500

Wireline gravatar image

Right I found the problem. I recently installed Jetpack 3.1 on an nvidia TX2, which somehow affects the apt-get update command on the host machine and the TX2. You cannot update anything, and so my ROS packages were out of date despite believing I had updated them (that'll teach me to ignore update terminal output).

Now I have run the update, everything works fine. For a workaround on the TX2 issue, see this nvidia forum post https://devtalk.nvidia.com/default/to... . There may be further topics on it, so search around. I dont know if its fixed in the latest jetpack versions, so one to be aware of if you just got a TX2

edit flag offensive delete link more

Comments

I get similar problem too. Can you describe more detail how you update TX2, thanks a lot

KSWang gravatar imageKSWang ( 2018-08-08 08:14:08 -0500 )edit

Your Answer

Please start posting anonymously - your entry will be published after you log in or create a new account.

Add Answer

Question Tools

2 followers

Stats

Asked: 2018-01-09 13:37:11 -0500

Seen: 698 times

Last updated: Jan 13 '18