Turtlebot3 navigation lost service connection when profiling with Valgrind

asked 2017-11-11 00:50:13 -0600

oiz5201618 gravatar image

I followed the guide to tried the Turtlebot3 navigation with Gazebo simulation, and everything worked fine.

However, when I added the following argument in turtlebot3_navigation/launch/turtlebot3_navigation.launch, some parts seems to be broken.

<node pkg="move_base" type="move_base" respawn="false" name="move_base" output="screen" launch-prefix="valgrind --tool=callgrind" >

The command roslaunch turtlebot3_navigation turtlebot3_navigation.launch map_file:=$HOME/map.yaml get the following info:

... logging to /home/shaohua/.ros/log/ffe180e2-c6a1-11e7-9b70-6045cb61bc51/roslaunch-hua-14980.log
Checking log directory for disk usage. This may take awhile.
Press Ctrl-C to interrupt
Done checking log file disk usage. Usage is <1GB.

xacro: Traditional processing is deprecated. Switch to --inorder processing!
To check for compatibility of your document, use option --check-order.
For more infos, see http://wiki.ros.org/xacro#Processing_Order
started roslaunch server http://hua:34059/



## parameters arugment ##

    amcl (amcl/amcl)
    map_server (map_server/map_server)
    move_base (move_base/move_base)
    robot_state_publisher (robot_state_publisher/robot_state_publisher)


core service [/rosout] found
process[robot_state_publisher-1]: started with pid [15001]
process[map_server-2]: started with pid [15002]
process[amcl-3]: started with pid [15003]
process[move_base-4]: started with pid [15005]
==15005== Callgrind, a call-graph generating cache profiler
==15005== Copyright (C) 2002-2015, and GNU GPL'd, by Josef Weidendorfer et al.
==15005== Using Valgrind-3.11.0 and LibVEX; rerun with -h for copyright info
==15005== Command: /home/shaohua/Develope/catkin_ws/devel/lib/move_base/move_base cmd_vel:=/cmd_vel odom:=odom __name:=move_base __log:=/home/shaohua/.ros/log/ffe180e2-c6a1-11e7-9b70-6045cb61bc51/move_base-4.log
==15005== For interactive control, run 'callgrind_control -h'.
[ INFO] [1510379496.601127874, 1017.916000000]: Using plugin "static_layer"
[ INFO] [1510379496.943013903, 1018.037000000]: Requesting the map...
[ INFO] [1510379497.199085295, 1018.493000000]: Resizing costmap to 384 X 384 at 0.050000 m/pix
[ INFO] [1510379497.342351029, 1018.626000000]: Received a 384 X 384 map at 0.050000 m/pix
[ INFO] [1510379497.547787110, 1018.655000000]: Using plugin "obstacle_layer"
[ INFO] [1510379497.587373696, 1018.692000000]:     Subscribed to Topics: scan
[ INFO] [1510379498.021323315, 1019.072000000]: Using plugin "inflation_layer"
[ INFO] [1510379499.228755178, 1019.876000000]: Using plugin "obstacle_layer"
[ INFO] [1510379499.313085974, 1020.098000000]:     Subscribed to Topics: scan
[ INFO] [1510379499.453659479, 1020.297000000]: Using plugin "inflation_layer"
[ WARN] [1510379499.679555905, 1020.607000000]: Costmap2DROS transform timeout. Current time: 1020.6070, global_pose stamp: 1018.4840, tolerance: 2.0000
[ INFO] [1510379499.970960188, 1020.948000000]: Created local_planner dwa_local_planner/DWAPlannerROS
[ INFO] [1510379500.056267738, 1020.979000000]: Sim period is set to 0.33
[ WARN] [1510379500.759995019, 1021.865000000]: Costmap2DROS transform timeout. Current time: 1021.8650, global_pose stamp: 1018.4840, tolerance: 2.0000
[ INFO] [1510379501.890491261, 1022.881000000]: Recovery behavior will clear layer obstacles
[ INFO] [1510379502.025401841, 1023.151000000]: Recovery behavior will clear layer obstacles

And the following is information from roswtf:

Loaded plugin tf.tfwtf
Package: turtlebot3_navigation
Static checks summary:

No errors or warnings
Beginning tests of your ROS graph. These may take awhile...
analyzing graph...
... done analyzing graph
running graph rules...
... done running graph rules
running tf checks, this will take a second...
... tf checks complete

Online checks summary:

Found 2 warning(s).
Warnings are things that may be just fine, but are sometimes at fault

WARNING The following node ...
edit retag flag offensive close merge delete