Ask Your Question
1

ar_track_alvar running too slow(~1hz)

asked 2017-11-10 17:51:10 -0500

eric_cartman gravatar image

I am using a logitech c920 to detect a marker. I am running pr2_indiv_no_kinect launch file of the ar_track_avlar ros package. But the thing is only running at 1hz. In the node file, it says there is a parameter called max_frequency which is already set to 8.0 and I tried to set it to 30 but nothing changed. Anyone know how to get it to run faster?

edit retag flag offensive close merge delete

Comments

What hardware are you running this on? And what is the resolution of the camera images?

ar_track_alvar should run over 20 hz easily on most PC's these days.

PeteBlackerThe3rd gravatar imagePeteBlackerThe3rd ( 2018-01-18 05:42:58 -0500 )edit

1 Answer

Sort by ยป oldest newest most voted
0

answered 2019-09-27 11:55:24 -0500

EugVal gravatar image

updated 2019-09-27 11:56:21 -0500

The answer here worked for me:

I.e adding <param name="max_frequency" type="double" value="10" /> to the node tag in the launch file allowed me to control the publication frequency of ar_track_alvar.

edit flag offensive delete link more

Your Answer

Please start posting anonymously - your entry will be published after you log in or create a new account.

Add Answer

Question Tools

2 followers

Stats

Asked: 2017-11-10 17:51:10 -0500

Seen: 60 times

Last updated: Sep 27