Ask Your Question
0

N: Ignoring file 'ros-latest' in directory '/et/apt/sources.list.d/' as it has no filename extention filename extention

asked 2017-11-08 01:51:14 -0600

thomn gravatar image

in step 1.4 i got this error .help me

edit retag flag offensive close merge delete

1 Answer

Sort by ยป oldest newest most voted
0

answered 2017-11-08 02:43:50 -0600

gvdhoorn gravatar image

Ignoring file 'ros-latest' in directory '/et/apt/sources.list.d/' as it has no filename extention filename extension

Perhaps surprisingly, this error seems to be pretty explanatory by itself.

The ros-latest file in /etc/apt/sources.list.d is supposed to have a .list extension, and it doesn't on your machine.

If with step 1.4 you are referring to the Installation step in the installation manual, then you may have made a mistake in step 1.2 - Setup your sources:

Setup your computer to accept software from packages.ros.org .

sudo sh -c 'echo "deb http://packages.ros.org/ros/ubuntu $(lsb_release -sc) main" > /etc/apt/sources.list.d/ros-latest.list'

Notice the .list extension there.

To resolve this, you could do something like the following:

sudo mv /etc/apt/sources.list.d/ros-latest /etc/apt/sources.list.d/ros-latest.list

then try sudo apt-get update again.

edit flag offensive delete link more

Your Answer

Please start posting anonymously - your entry will be published after you log in or create a new account.

Add Answer

Question Tools

Stats

Asked: 2017-11-08 01:51:14 -0600

Seen: 3,112 times

Last updated: Nov 08 '17