Velocity setting for topic joint_path_command

asked 2017-11-07 13:04:33 -0600

linshenzhen gravatar image

updated 2017-11-07 15:11:40 -0600

I am using the topic joint_path_command from the ros-industrial (link) for robot joint control. More specifically, I am using Orebro's YuMi repo (link) with the industrial-core (kinetic branch).

Now I am publishing just one point trajectory to the topic with desired joint values closed to the current positions. If I leave the velocity field blank in the trajectory_msgs/JointTrajectory for the trajectory point, the robot moves smooth but slow. When I set the velocity field with a value, the robot moves very slow (slower than without setting it), even with a very large value for the velocity. I started the velocity with 0.1 and increase it to 500000, but there is not much different.

How can I increase the robot velocity when using the joint_path_command topic for the robot control?

edit retag flag offensive close merge delete

Comments

1

This is a duplicate of OrebroUniversity/yumi#28.

Please do not post duplicate questions.

gvdhoorn gravatar image gvdhoorn  ( 2017-11-07 14:27:52 -0600 )edit

For future questions: please include all relevant information. I happen to know that you are actually using Orebro's YuMi fork of the ABB driver, but without that information, your question is unanswerable.

gvdhoorn gravatar image gvdhoorn  ( 2017-11-07 14:29:54 -0600 )edit

@gvdhoorn Sorry for the duplicated question. I was not sure if this is a general ros-industrial issue or specific to the Orebro Yumi repo. I was hoping to get answers from one of the source and close the other when it is solved. Please let me know what other information is required.

linshenzhen gravatar image linshenzhen  ( 2017-11-07 15:04:04 -0600 )edit

The problem with cross-posting is that it leads to split discussions, which can lead to multiple posters providing the same advice, which is a waste of time on both sides.

gvdhoorn gravatar image gvdhoorn  ( 2017-11-08 03:32:20 -0600 )edit