Network Mistake

asked 2017-11-02 09:38:52 -0500

Dornier gravatar image

Hello! I've been trying to configure communication between laptop and youbot Kuka using wireless network. ROS installed on the laptop is Kinetic and ROS installed on the mobile robot is Hydro. In my opinion i configured correctly .bashrc files on the two machines. The laptop is master. When i start

roscore

and

 rosrun turtlesim turtelesim_node

on the master machine everything is fine. However..when i write

rostopic list

on the slave machine (kuka Youbot) there is a mistake and i don't know how to solve the problem. I will be very grateful to help. The error is:

youbot@ubuntu:~$ rostopic list
Traceback (most recent call last):
  File "/opt/ros/hydro/bin/rostopic", line 35, in <module>
    rostopic.rostopicmain()
  File "/opt/ros/hydro/lib/python2.7/dist-packages/rostopic/__init__.py", line 1673, in rostopicmain
    _rostopic_cmd_list(argv)
  File "/opt/ros/hydro/lib/python2.7/dist-packages/rostopic/__init__.py", line 1614, in _rostopic_cmd_list
    exitval = _rostopic_list(topic, verbose=options.verbose, subscribers_only=options.subscribers, publishers_only=options.publishers, group_by_host=options.hostname) or 0
  File "/opt/ros/hydro/lib/python2.7/dist-packages/rostopic/__init__.py", line 860, in _rostopic_list
    master = rosgraph.Master('/rostopic')
  File "/opt/ros/hydro/lib/python2.7/dist-packages/rosgraph/masterapi.py", line 100, in __init__
    self._reinit(master_uri)
  File "/opt/ros/hydro/lib/python2.7/dist-packages/rosgraph/masterapi.py", line 118, in _reinit
    raise ValueError("invalid master URI: %s"%(master_uri))
ValueError: invalid master URI: 192.168.1.248:11311
edit retag flag offensive close merge delete

Comments

How do you connect to your robot? Have you seen multiple_machines and network_setup guides?

l4ncelot gravatar image l4ncelot  ( 2017-11-02 09:49:58 -0500 )edit
clyde gravatar image clyde  ( 2017-11-02 09:50:31 -0500 )edit

It was a spelling mistake. The row inside my /.bashrc file was:

export ROS_MASTER_URI=master_hostname:11311

The correct version is:

export ROS_MASTER_URI=http://master_hostname:11311
Dornier gravatar image Dornier  ( 2017-11-02 10:39:38 -0500 )edit

Does it solve your problem then?

l4ncelot gravatar image l4ncelot  ( 2017-11-02 11:16:52 -0500 )edit

Yes it solved the problem

Dornier gravatar image Dornier  ( 2017-11-02 15:56:18 -0500 )edit