Ask Your Question
1

rgbdslamv2 segfault shortly after startup

asked 2017-10-30 10:06:36 -0500

rnunziata gravatar image

updated 2017-10-30 10:10:03 -0500

rgbdslamv2 segfault shortly after startup . Trace below generated via xterm gbd in launch file. System comes up looks ok starts to run then sefaults during display. Tried running headless with same results. Any idea what is causing this. I am running ubuntu16.

[ INFO] [1509375314.160750258, 1305033527.867128886]: RANSAC found a valid transformation with 298 inliers matches with average ratio 0.097409
[ INFO] [1509375314.160762053, 1305033527.867128886]: Returning Valid Edge
[ INFO] [1509375314.160819035, 1305033527.867128886]: Result of comparison 0: 
[ INFO] [1509375314.160848306, 1305033527.867128886]: Rotation: 0.53, Distance:  0.009m
[ INFO] [1509375314.160866383, 1305033527.867128886]: Rotation: 0.53, Distance:  0.009m
[ INFO] [1509375314.160911549, 1305033527.867128886]: Added Edge between 0 and 1. Inliers: 298
[ INFO] [1509375314.160940682, 1305033527.867128886]: Adding node with id 1 and seq id 1 to the graph
[ INFO] [1509375314.160960472, 1305033527.867128886]: create cloud 1 1 0
[ INFO] [1509375314.166014054, 1305033527.867128886]: No change to renderer skip (1).
[ INFO] [1509375314.166122771, 1305033527.867128886]: Added Node, new graphsize: 2 nodes
[ WARN] [1509375314.166280803, 1305033527.867128886]: Loop Closures: 0, Sequential Edges: 1
[ WARN] [1509375314.166301659, 1305033527.867128886]: Starting Optimization
[ INFO] [1509375314.166319108, 1305033527.867128886]: Added, Camera Pose Graph Size: 2N/1E, Duration: 0.008553, Inliers:  298
[ WARN] [1509375314.166373657, 1305033527.867128886]: Optimization with 2 cams, 7526752397134135296 nodes and 3403715683584009314 edges in the graph

Thread 44 "Thread (pooled)" received signal SIGSEGV, Segmentation fault.
[Switching to Thread 0x7fff467fc700 (LWP 2496)]
0x00007ffff75552c7 in g2o::OptimizationAlgorithmLevenberg::computeLambdaInit() const ()

after segfault execution of bt

bt

#0  0x00007ffff75552c7 in g2o::OptimizationAlgorithmLevenberg::computeLambdaInit() const () from /home/rjn/catkin_ws/src/rgbdslam/Thirdparty/g2o/install/lib/libg2o_core.so
#1  0x00007ffff75556fa in g2o::OptimizationAlgorithmLevenberg::solve(int, bool) () from /home/rjn/catkin_ws/src/rgbdslam/Thirdparty/g2o/install/lib/libg2o_core.so
#2  0x00007ffff754d0c7 in g2o::SparseOptimizer::optimize(int, bool) () from /home/rjn/catkin_ws/src/rgbdslam/Thirdparty/g2o/install/lib/libg2o_core.so
#3  0x0000000000581d7c in GraphManager::optimizeGraphImpl(double) ()
#4  0x000000000058f2d9 in QtConcurrent::RunFunctionTask<double>::run() ()
#5  0x00007fffee5a72d3 in ?? () from /usr/lib/x86_64-linux-gnu/libQt5Core.so.5
#6  0x00007fffee5aa7be in ?? () from /usr/lib/x86_64-linux-gnu/libQt5Core.so.5
#7  0x00007fffefac56ba in start_thread (arg=0x7fff467fc700) at pthread_create.c:333
#8  0x00007fffeda883dd in clone () at ../sysdeps/unix/sysv/linux/x86_64/clone.S:109
edit retag flag offensive close merge delete

1 Answer

Sort by ยป oldest newest most voted
0

answered 2017-11-28 04:18:38 -0500

dljubic gravatar image

How did you install it? Did you use installation from scratch?

I was having the same problem as you until I removed ros-kinetic-libg2o.

$sudo apt-get purge ros-kinetic-libg2o

After doing that, just recompile g2ofork and

$catkin_make --pkg rgbdslam

But make sure that rgbdslam package uses g2ofork! You can look at the install from scratch script that is provided as an installation option to make sure that you are doing everything right. If you have further questions, feel free to ask. :)

edit flag offensive delete link more

Comments

How would that affect ros? Is there a way to make it a third party compile . Thanks for your input.

rnunziata gravatar image rnunziata  ( 2017-11-30 11:49:54 -0500 )edit

Your Answer

Please start posting anonymously - your entry will be published after you log in or create a new account.

Add Answer

Question Tools

1 follower

Stats

Asked: 2017-10-30 10:06:36 -0500

Seen: 93 times

Last updated: Oct 30 '17