Ask Your Question
0

Problems with 2D Nav Goal RViz

asked 2017-10-26 13:00:16 -0500

ltelang gravatar image

I am working with the TurtleBot 3. I went through all the proper steps for bring up and teleop on the Turtlebot website. When I get to the Navigation section I am all set with the TurtleBot Burger running in the simulator. I can teleop the robot with my keyboard, and the robot moves, updates, and the green arrows update on my map file I created and saved with the SLAM function. However! When I go to set a 2D Nav Goal the red arrow is dropped on the software but my robot does not move at all.

On the terminal where I ran the line of code from the website: roslaunch turtlebot3_navigation turtlebot3_navigation.launch map_file:=$HOME/hall_map.yaml

I GET THE ERROR: [ WARN] [1509040330.685373661]: Costmap2DROS transform timeout. Current time: 1509040330.6853, global_pose stamp: 1455210624.3528, tolerance: 1.0000

repeatedly

Also on the nav.RViz software on the left side bar there are status warnings for Costmap and Map and the message says No map received.

I am running Ubuntu 16 and ROS Kinetic

Please let me know if anyone can help

edit retag flag offensive close merge delete

Comments

Have you tried to kill the teleoperation? Have you tried this ? https://github.com/ROBOTIS-GIT/turtle... I still have the exact same problem, have you solved it?

hansenmaster gravatar image hansenmaster  ( 2018-10-01 21:24:01 -0500 )edit

Have you fixed this issue? I have the same problem with the same message however, the map that I send has recived. I've changed a lot of parameter but nothing works. Have you got the solution?

samadrigal7 gravatar image samadrigal7  ( 2019-02-18 17:20:09 -0500 )edit

Have you found a solution for this ? I am facing the same problem.

Ngoc-Thinh Nguyen gravatar image Ngoc-Thinh Nguyen  ( 2020-05-13 06:31:04 -0500 )edit

1 Answer

Sort by ยป oldest newest most voted
0

answered 2020-05-13 08:16:45 -0500

The problem is that date and time on Remote PC and on the Turtlebot are not synchronized. The solution is to call the Network Time Protocol (NTP) server everytime before launching the navigation process by using:

sudo ntpdate ntp.ubuntu.com

Note that, the NTP server should be updated in both the Remote PC and the TurtleBot:

sudo apt-get install ntpdate

edit flag offensive delete link more

Your Answer

Please start posting anonymously - your entry will be published after you log in or create a new account.

Add Answer

Question Tools

1 follower

Stats

Asked: 2017-10-26 12:59:27 -0500

Seen: 630 times

Last updated: Oct 26 '17