ROS Resources: Documentation | Support | Discussion Forum | Index | Service Status | ros @ Robotics Stack Exchange
Ask Your Question

pointcloud_to_laserscan with ldmrs data

asked 2017-10-24 03:16:13 -0500

grapeson gravatar image

updated 2017-10-24 09:12:54 -0500

jayess gravatar image


I am trying to covert Pointcloud2 msgs obtained by a SICK LD-MRS four layer scanner to Laserscan msgs. i tried to use the pointcloud_to_laserscan package, but it did not work. Following is what i get:

$ roslaunch pointcloud_to_laserscan sample_node.launch

logging to /home/grapeson/.ros/log/c4b31a3c-b80d-11e7-b725-141877a62928/roslaunch-grapeson-Inspiron.log
Checking log directory for disk usage. This may take awhile.
Press Ctrl-C to interrupt
Done checking log file disk usage. Usage is <1GB.

Traceback (most recent call last):

  File "/opt/ros/kinetic/lib/python2.7/dist-packages/roslaunch/", line 307, in main

  File "/opt/ros/kinetic/lib/python2.7/dist-packages/roslaunch/", line 268, in start

  File "/opt/ros/kinetic/lib/python2.7/dist-packages/roslaunch/", line 217, in _start_infrastructure

  File "/opt/ros/kinetic/lib/python2.7/dist-packages/roslaunch/", line 132, in _load_config
    roslaunch_strs=self.roslaunch_strs, verbose=self.verbose)

  File "/opt/ros/kinetic/lib/python2.7/dist-packages/roslaunch/", line 451, in load_config_default
    loader.load(f, config, verbose=verbose)

  File "/opt/ros/kinetic/lib/python2.7/dist-packages/roslaunch/", line 746, in load
    self._load_launch(launch, ros_config, is_core=core, filename=filename, argv=argv, verbose=verbose)

  File "/opt/ros/kinetic/lib/python2.7/dist-packages/roslaunch/", line 718, in _load_launch
    self._recurse_load(ros_config, launch.childNodes, self.root_context, None, is_core, verbose)

  File "/opt/ros/kinetic/lib/python2.7/dist-packages/roslaunch/", line 682, in _recurse_load
    val = self._include_tag(tag, context, ros_config, default_machine, is_core, verbose)

  File "/opt/ros/kinetic/lib/python2.7/dist-packages/roslaunch/", line 95, in call
    return f(*args, **kwds)

  File "/opt/ros/kinetic/lib/python2.7/dist-packages/roslaunch/", line 587, in _include_tag
    inc_filename = self.resolve_args(tag.attributes['file'].value, context)

  File "/opt/ros/kinetic/lib/python2.7/dist-packages/roslaunch/", line 183, in resolve_args
    return substitution_args.resolve_args(args, context=context.resolve_dict, resolve_anon=self.resolve_anon)

  File "/opt/ros/kinetic/lib/python2.7/dist-packages/roslaunch/", line 370, in resolve_args
    resolved = _resolve_args(resolved, context, resolve_anon, commands)

  File "/opt/ros/kinetic/lib/python2.7/dist-packages/roslaunch/", line 383, in _resolve_args
    resolved = commands[command](resolved, a, args, context)

  File "/opt/ros/kinetic/lib/python2.7/dist-packages/roslaunch/", line 151, in _find

  File "/opt/ros/kinetic/lib/python2.7/dist-packages/roslaunch/", line 197, in _find_executable
    full_path = _get_executable_path(rp.get_path(args[0]), path)

  File "/usr/lib/python2.7/dist-packages/rospkg/", line 203, in get_path
    raise ResourceNotFound(name, ros_paths=self._ros_paths)

**ResourceNotFound: openni2_launch**

ROS path [0]=/opt/ros/kinetic/share/ros

ROS path [1]=/opt/ros/kinetic/share

*It reports that "ResourceNotFound: openni2_launch", and then I tried *

$ rospack find openni2

*and i get *

[rospack] Error: package 'openni2' not found

What can I do now? can anybody help? Thanks

edit retag flag offensive close merge delete


Welcome! To make your question easier to read (and hopefully get more people reading it) I formatted your text. Please use the 101010 button to format your code and terminal input/output in the future.

jayess gravatar image jayess  ( 2017-10-24 09:14:19 -0500 )edit

Thanks a lot!`

grapeson gravatar image grapeson  ( 2017-10-27 07:50:20 -0500 )edit

1 Answer

Sort by » oldest newest most voted

answered 2017-11-06 10:52:19 -0500

grapeson gravatar image

This is really a stupid question. we should adjust the launch file.

edit flag offensive delete link more


What do you mean? How should you adjust the launch file?

jayess gravatar image jayess  ( 2017-11-06 12:40:10 -0500 )edit

Question Tools



Asked: 2017-10-24 03:16:13 -0500

Seen: 246 times

Last updated: Nov 06 '17