Ask Your Question
0

cannot roslaunch rbx2_bringup pi_robot_with_gripper.launch

asked 2017-10-12 07:38:19 -0500

tengfei gravatar image

updated 2017-10-12 09:04:09 -0500

jayess gravatar image

Hi everyone. I'm learning ros_by_example step by step. When I have installed the packages required by the book and tried the command roslaunch rbx2_bringup pi_robot_with_gripper.launch sim:=true there are some mistakes like

ERROR: cannot launch node of type [arbotix_python/arbotix_driver]: arbotix_python
ROS path [0]=/opt/ros/indigo/share/ros
ROS path [1]=/home/shantengfei/catkin_ws/src
ROS path [2]=/opt/ros/indigo/share
ROS path [3]=/opt/ros/indigo/stacks` `ERROR: cannot launch node of type [arbotix_controllers/gripper_controller]: arbotix_controllers
ROS path [0]=/opt/ros/indigo/share/ros
ROS path [1]=/home/shantengfei/catkin_ws/src
ROS path [2]=/opt/ros/indigo/share
ROS path [3]=/opt/ros/indigo/stacks

I tried with the similiar method like this.But it did'nt work.I have put source /home/shantengfei/catkin_ws/devel/setup.bashin my ~/.bashrc and the ROS_PACKAGES_PATH is /home/shantengfei/catkin_ws/src:/opt/ros/indigo/share:/opt/ros/indigo/stacks.Could someone give me a solution?Thanks.

edit retag flag offensive close merge delete

Comments

Well as stated in the answer you found, it means ROS does not find your package, either because it's not installed or because you did not correctly linked it. Did you fixed your other issue, the one for which you asked a question not long ago. it seems to me that this one is linked to the other.

TTDM gravatar imageTTDM ( 2017-10-12 09:02:59 -0500 )edit

Thanks for your reply. I can find the rbx2 package using roscd/roslaunch, so I think taht this package has be installed.the formmer question is another package that was installed recnetly since I build the workspace I can find the same name folder in ~catkin_ws/build.

tengfei gravatar imagetengfei ( 2017-10-12 20:41:01 -0500 )edit
1

The package that isn't found is not rbx2, it is arbotix_python, can you look specially for this one and tell me if you have it ?

TTDM gravatar imageTTDM ( 2017-10-13 02:14:33 -0500 )edit

Sorry I didn't install the package.After I installed the package,it works!Thanks!But another problem I asked still unsloved.Could you please give me some suggestion?

tengfei gravatar imagetengfei ( 2017-10-13 03:45:03 -0500 )edit

2 Answers

Sort by ยป oldest newest most voted
0

answered 2017-10-13 04:03:57 -0500

TTDM gravatar image

updated 2017-10-13 04:11:09 -0500

Full answer with a few clarifications, based on the comments :

As stated in your link, this error means that ROS can not find the package arbotix_python either because it is not installed or because it has not been correctly linked.

Please note that this package has nothing to do with the packages from which you launch your launchfiles. Putting launchfiles in a package is simply a way to be able to easily call them ( using roslaunch <package_name> <launch_name> ) but you could also put your launch file in any directory, open a terminal in this directory and call roslaunch <launch_name> it would work perfectly.

Also note that when calling arbotix_python/arbotix_driver, if the package arbotix_python is found but not the node arbotix_driver then the error is : Canno't find node arbotix_driver in package arbotix_python

edit flag offensive delete link more
0

answered 2017-10-13 03:53:27 -0500

shyreckdc gravatar image

updated 2017-10-13 03:54:34 -0500

I have the same problem. TTDM' comment is really useful! I installed arbotix_python and it works now. Thank you very much!

edit flag offensive delete link more

Your Answer

Please start posting anonymously - your entry will be published after you log in or create a new account.

Add Answer

Question Tools

2 followers

Stats

Asked: 2017-10-12 07:38:19 -0500

Seen: 50 times

Last updated: Oct 13 '17