Ask Your Question
1

[SOLVED] catkin_make hangs forever

asked 2017-10-11 13:53:56 -0600

DHCustomPak gravatar image

updated 2018-01-09 16:14:44 -0600

ROS Indigo on Ubuntu 14.04 LTS

ROS Lunar on Ubuntu 16.04 LTS

catkin_make starts up and gets as far as BUILD_SHARED_LIBS is on and then hangs. There are no high cpu processes listed in top, and no output to dmesg at all.

What else can I check to investigate why it hangs?

Edit:

A clean install of Lunar worked fine until today.

ps aux | grep cmake

automat+  1996  0.0  0.3 153344 14328 pts/17   S+   15:16   0:00 cmake /home/automation/catkin_ws/src -DCATKIN_DEVEL_PREFIX=/home/automation/catkin_ws/devel -DCMAKE_INSTALL_PREFIX=/home/automation/catkin_ws/install -G Unix Makefiles
automat+  2078  0.1  0.4 276192 16644 pts/17   S+   15:16   0:00 /usr/bin/python /usr/bin/empy --raw-errors -F /home/automation/catkin_ws/build/catkin_generated/order_packages.py -o /home/automation/catkin_ws/build/catkin_generated/order_packages.cmake /opt/ros/lunar/share/catkin/cmake/em/order_packages.cmake.em
automat+  2114  0.0  0.3  57160 14012 pts/17   S+   15:16   0:00 /usr/bin/python /usr/bin/empy --raw-errors -F /home/automation/catkin_ws/build/catkin_generated/order_packages.py -o /home/automation/catkin_ws/build/catkin_generated/order_packages.cmake /opt/ros/lunar/share/catkin/cmake/em/order_packages.cmake.em
automat+  2115  0.0  0.3  56872 13940 pts/17   S+   15:16   0:00 /usr/bin/python /usr/bin/empy --raw-errors -F /home/automation/catkin_ws/build/catkin_generated/order_packages.py -o /home/automation/catkin_ws/build/catkin_generated/order_packages.cmake /opt/ros/lunar/share/catkin/cmake/em/order_packages.cmake.em
automat+  2390  0.0  0.0  21292   988 pts/1    S+   15:28   0:00 grep --color=auto cmake
env | grep -i ros | sort (in an auto-sourced terminal)
CMAKE_PREFIX_PATH=/home/automation/catkin_ws/devel:/opt/ros/lunar
LD_LIBRARY_PATH=/home/automation/catkin_ws/devel/lib:/opt/ros/lunar/lib
PATH=/home/automation/bin:/home/automation/.local/bin:/opt/ros/lunar/bin:/usr/local/sbin:/usr/local/bin:/usr/sbin:/usr/bin:/sbin:/bin:/usr/games:/usr/local/games:/snap/bin
PKG_CONFIG_PATH=/opt/ros/lunar/lib/pkgconfig
PYTHONPATH=/opt/ros/lunar/lib/python2.7/dist-packages
ROS_DISTRO=lunar
ROS_ETC_DIR=/opt/ros/lunar/etc/ros
ROSLISP_PACKAGE_DIRECTORIES=/home/automation/catkin_ws/devel/share/common-lisp
ROS_MASTER_URI=http://localhost:11311
ROS_PACKAGE_PATH=/home/automation/catkin_ws/src:/opt/ros/lunar/share
ROS_ROOT=/opt/ros/lunar/share/ros

Edit 10/19/17: apt-cache policy python-empy

python-empy:
  Installed: 3.3.2-1build1
  Candidate: 3.3.2-1build1
  Version table:
 * 3.3.2-1build1 500
        500 http://us.archive.ubuntu.com/ubuntu xenial/universe amd64 Packages
        500 http://us.archive.ubuntu.com/ubuntu xenial/universe i386 Packages
        100 /var/lib/dpkg/status
pip list | grep empy
empy (3.3.2)
You are using pip version 8.1.1, however version 9.0.1 is available.
You should consider upgrading via the 'pip install --upgrade pip' command.
automation@atc-nuc-ros:~$ pip install --upgrade pip
Collecting pip
  Downloading pip-9.0.1-py2.py3-none-any.whl (1.3MB)
    100% |████████████████████████████████| 1.3MB 470kB/s
Installing collected packages: pip
Successfully installed pip-8.1.1
You are using pip version 8.1.1, however version 9.0.1 is available.
You should ...
(more)
edit retag flag offensive close merge delete

Comments

Delete build and devel, and try running things as follows:

catkin_make VERBOSE=1

If things hang, see what it was doing.

Seeing the order_package.py in that ps output: how many packages do you have, and what sort of machine is this?

gvdhoorn gravatar imagegvdhoorn ( 2017-10-18 02:43:04 -0600 )edit

Verbose output: https://pastebin.com/DiDiuGfZ Still hangs after BUILD_SHARE_LIBS is on.

We have one package with 8 nodes. This machine is an Intel NUC, we previously used a Surface Pro 3 that worked flawlessly for the past year or more, then recently stopped working.

DHCustomPak gravatar imageDHCustomPak ( 2017-10-18 08:25:33 -0600 )edit

Does catkin_tools work? That is not a solution, but just trying to get some more info.

gvdhoorn gravatar imagegvdhoorn ( 2017-10-18 08:32:08 -0600 )edit

catkin_tools: command not found

Is it a command I should be running? Do I need to have something else installed first? I did the ros-lunar-desktop-full install.

DHCustomPak gravatar imageDHCustomPak ( 2017-10-18 08:41:43 -0600 )edit
gvdhoorn gravatar imagegvdhoorn ( 2017-10-18 09:01:11 -0600 )edit

catkin build just ran for an hour and didn't get anywhere...

DHCustomPak gravatar imageDHCustomPak ( 2017-10-18 10:49:02 -0600 )edit

Let's take a step back: can you build an empty workspace (with catkin_make or catkin build, I don't care). So:

  1. open a new terminal (no auto sourcing anything)
  2. source /opt/ros/$distro/setup.bash
  3. mkdir -p /tmp/empty_ws/src
  4. cd /tmp/empty_ws
  5. catkin_make
gvdhoorn gravatar imagegvdhoorn ( 2017-10-18 10:52:38 -0600 )edit

I followed your instructions exactly and it behaves the same as before. Hangs after BUILD_SHARED_LIBS is on :(

Thank you for your help, I really appreciate it! We are definitely at our wit's end with this thing and none of the similar issues we found online had a working solution.

DHCustomPak gravatar imageDHCustomPak ( 2017-10-18 10:57:10 -0600 )edit

1 Answer

Sort by » oldest newest most voted
1

answered 2018-01-09 16:14:19 -0600

DHCustomPak gravatar image

There was a single package in our system that did not adhere to the naming conventions (package name contains capital letters). Catkin threw a warning and then hung on build until the package was removed/renamed.

It wasn't obvious that it was a fatal error considering the message was prefixed with "Warning" and not "Error".

edit flag offensive delete link more

Comments

Thanks for reporting back.

Not adhering to naming conventions should definitely not be a fatal error or cause Catkin to hang.

If you can create an MWE and report it here that would be great.

gvdhoorn gravatar imagegvdhoorn ( 2018-01-10 02:26:19 -0600 )edit

Your Answer

Please start posting anonymously - your entry will be published after you log in or create a new account.

Add Answer

Question Tools

2 followers

Stats

Asked: 2017-10-11 13:53:56 -0600

Seen: 2,321 times

Last updated: Jan 09 '18