ROS Resources: Documentation | Support | Discussion Forum | Service Status | Q&A answers.ros.org
Ask Your Question
0

Error when trying to launch moveit created robot model

asked 2017-09-28 10:16:09 -0500

Fiddle gravatar image

I am trying to create a simulated robot in Gazebo that can be operated with use of the Moveit. I created a robot using moveit assistant, placed it in catkin workspace folder and built it. But when I try to launch it, i get an error, that says:

You can start planning now!

[ INFO] [1506611133.048666841]: Stereo is NOT SUPPORTED
[ INFO] [1506611133.048829426]: OpenGl version: 4.5 (GLSL 4.5).
terminate called after throwing an instance of 'Ogre::Exception'
what():  OGRE EXCEPTION(5:): Could not find font Liberation Sans in MovableText::setFontName

I checked for the liberation sans font with synaptic, even reinstalled it, but the error remains.

edit retag flag offensive close merge delete

Comments

Note btw that this is most likely not a problem with your MoveIt configuration, but with RViz. You could verify that by running just RViz (using something like rosrun rviz rviz or just rviz).

gvdhoorn gravatar imagegvdhoorn ( 2017-09-28 10:55:44 -0500 )edit

the rviz runs normally when i try that

Fiddle gravatar imageFiddle ( 2017-09-28 11:08:31 -0500 )edit

You have to add it (paste it) interested RVIZ font directory NOT the one of your Linux system, the RVIZ directory directly

ddomit gravatar imageddomit ( 2017-10-07 12:58:34 -0500 )edit

3 Answers

Sort by ยป oldest newest most voted
1

answered 2017-09-28 12:41:44 -0500

William gravatar image

updated 2017-11-13 10:56:07 -0500

This shouldn't be required, the real solution is for moveit to make sure they have the fonts they use, or ensure that they are using the same font as rviz. I would look to a resolution to https://github.com/ros-planning/movei... for a permanent solution.

EDIT: update is that this is caused by a configuration issue with when building from source. Make sure that if you're building rviz from source that you have the latest sources and that you've rebuilt your workspace (delete the build, devel, and install folders and build it again) as well as having your deb packages up-to-date (sudo apt-get update then sudo apt-get install ros-kinetic-rviz or sudo apt-get dist-upgrade).

edit flag offensive delete link more
0

answered 2017-09-29 14:14:02 -0500

ddomit gravatar image

I just fixed it, you have to get the liberation fonts in the rviz fonts directory directly. It doesn't matter if you have it installed in your system, you have to add them directly in the rviz fonts folder.

Hope it helps!

edit flag offensive delete link more

Comments

1

How do you locate the rviz fonts directory?

dowusu gravatar imagedowusu ( 2017-10-06 22:16:30 -0500 )edit
-1

answered 2017-11-13 03:00:08 -0500

jylee0121 gravatar image

Version mismatching between rviz and moveit causes this issues. moveit! rviz plugin is trying to use "Liberation Sans" font but old version of rviz don't have the font in "/opt/ros/kinetic/share/rviz/ogre_media/".

The related rviz commit is here: https://github.com/ros-visualization/...

After cloning the latest source code and copying Liberation Sans font (all related files) into /opt/ros/kinetic/share/rviz/ogre_media/, It will work.

fonts-liberation package is not the reason of the issue.

edit flag offensive delete link more

Comments

You should not need to copy anything into /opt/ros/kinetic/share/rviz/ogre_media manually.

William gravatar imageWilliam ( 2017-11-13 10:53:48 -0500 )edit

@William you updated your answers . Updating proper version rviz is a clearer solution. I thought that moveit deb package manager SHOULD put rviz VERSION dependency constraint into moveit deb package.

jylee0121 gravatar imagejylee0121 ( 2017-11-13 18:55:15 -0500 )edit

Your Answer

Please start posting anonymously - your entry will be published after you log in or create a new account.

Add Answer

Question Tools

2 followers

Stats

Asked: 2017-09-28 10:16:09 -0500

Seen: 864 times

Last updated: Nov 13 '17