Ask Your Question
0

rviz doesn't show any shape

asked 2017-09-22 10:38:13 -0500

Maik993 gravatar image

Hi all, I'm trying to build my first URDF model, following this tutorial: http://wiki.ros.org/urdf/Tutorials/Bu...

Booth replicating what's done there, and cloning this repo too, I can't see any mash or shape in rviz, only transformations; here's what I see from chap.4 code:

image description

There should be cylinders and squares...

Anyone experiencing this issue? I'm running ROS Lunar, Ubuntu 17.04 x64 on VirtualBox (with "3D acceleration" disabled because i don't know why, if it's enabled rviz trows segmentation faults at start)

Side note: chap.1 I think it's buggy because with no joints there's not any "base_link" transformation supplied by joint_state_publisher, and Rviz go crazy...

edit retag flag offensive close merge delete

Comments

We're probably going to have to see what the contents of your URDF is.

gvdhoorn gravatar imagegvdhoorn ( 2017-09-23 16:51:19 -0500 )edit

I went further and complete the model, the result is an exact copy of this. In rviz I still don't see any shape, but launching the same file in Gazebo produce a correct visualisation of the entire robot.

Maik993 gravatar imageMaik993 ( 2017-09-24 05:12:55 -0500 )edit

This could be caused by locale settings. See ros-visualization/rviz#1151.

gvdhoorn gravatar imagegvdhoorn ( 2017-11-20 09:26:37 -0500 )edit

2 Answers

Sort by ยป oldest newest most voted
1

answered 2017-09-25 15:38:53 -0500

David Lu gravatar image

This is likely a problem with RViz/VirtualBox, and not your URDF.

edit flag offensive delete link more
3

answered 2018-07-09 17:11:01 -0500

dhood gravatar image

Highlighting @gvdhoorn's previous suggestion (for others that come across this issue) that the issue may be related to locales.

Some rviz users have encountered a similar issue on newer ubuntu/debian versions e.g. ROS Lunar on Ubuntu Artful or ROS Melodic on Ubuntu Bionic (see for example: https://github.com/ros-visualization/... ).

If that's the underlying issue, modifying the following environment variable will fix it:

export LC_NUMERIC="en_US.UTF-8".

edit flag offensive delete link more

Your Answer

Please start posting anonymously - your entry will be published after you log in or create a new account.

Add Answer

Question Tools

1 follower

Stats

Asked: 2017-09-22 10:38:13 -0500

Seen: 752 times

Last updated: Jul 09 '18