ROS Resources: Documentation | Support | Discussion Forum | Index | Service Status | ros @ Robotics Stack Exchange
Ask Your Question

something is wrong when i run turtlesim_node

asked 2017-09-19 01:43:33 -0500

summer gravatar image

I am a beginner, I am learning I use the ‘indigo’ version
when i run this "rosrun turtlesim turtlesim_node"
The screen display [ERROR] [1505802741.783016851]: [registerPublisher] Failed to contact master at [localhost:11311]. retrying... How to resolve this problem?

edit retag flag offensive close merge delete

1 Answer

Sort by » oldest newest most voted

answered 2017-09-20 04:07:28 -0500

Do you initialized the ros? with the roscore?

Try type the command " roscore " before. In another terminal's window

edit flag offensive delete link more


Ok ,it is working .Thank you very much.

summer gravatar image summer  ( 2017-09-20 22:24:00 -0500 )edit

@summer, if this answered your question then please click the checkmark to accept the answer.

jayess gravatar image jayess  ( 2017-09-21 00:25:49 -0500 )edit

Question Tools


Asked: 2017-09-19 01:43:33 -0500

Seen: 179 times

Last updated: Sep 20 '17