Ask Your Question
0

roscd: No such package/stack 'beginner_tutorials'

asked 2017-09-16 16:33:07 -0500

ahmedadelhekal gravatar image

updated 2017-09-18 22:31:30 -0500

when i run roscd i got this error ????

roscd: No such package/stack 'beginner_tutorials'

update

ahmed@ahmed-HP-Casablanca-H510:~/catkin_ws$ source devel/setup.bash 
ahmed@ahmed-HP-Casablanca-H510:~/catkin_ws$ catkin_make 
Base path: /home/ahmed/catkin_ws
Source space: /home/ahmed/catkin_ws/src
Build space: /home/ahmed/catkin_ws/build
Devel space: /home/ahmed/catkin_ws/devel
Install space: /home/ahmed/catkin_ws/install
####
#### Running command: "make cmake_check_build_system" in "/home/ahmed/catkin_ws/build"
####
####
#### Running command: "make -j8 -l8" in "/home/ahmed/catkin_ws/build"
####
ahmed@ahmed-HP-Casablanca-H510:~/catkin_ws$ roscd beginner_tutorials
roscd: No such package/stack 'beginner_tutorials'

new update i tried roscd profile and this the result

ahmed@ahmed-HP-Casablanca-H510:~/catkin_ws$ rospack profile
Full tree crawl took 0.021956 seconds.
Directories marked with (*) contain no manifest.  You may
want to delete these directories.
To get just of list of directories without manifests,
re-run the profile with --zombie-only
-------------------------------------------------------------
0.021130   /opt/ros/kinetic/share
0.000162 * /opt/ros/kinetic/share/OpenCV-3.2.0-dev
0.000036 * /opt/ros/kinetic/share/OpenCV-3.2.0-dev/haarcascades
0.000031 * /home/ahmed/catkin_ws/src
0.000029 * /opt/ros/kinetic/share/doc
0.000013 * /opt/ros/kinetic/share/OpenCV-3.2.0-dev/lbpcascades
0.000006 * /opt/ros/kinetic/share/doc/liborocos-kdl
ahmed@ahmed-HP-Casablanca-H510:~/catkin_ws$ ~/.ros/rospack_cache*
bash: /home/ahmed/.ros/rospack_cache_10864520700894273605: Permission denied
edit retag flag offensive close merge delete

Comments

Assuming that you have installed the package beginner_tutorials, try going to your catkin workspace, for example ~/catkin_ws and running source devel/setup.bash from the command line.

surfertas gravatar image surfertas  ( 2017-09-16 22:16:28 -0500 )edit

Thanx for reply but i tried this solution and it is not work for me

ahmed@ahmed-HP-Casablanca-H510:~/catkin_ws$ source devel/setup.bash
ahmed@ahmed-HP-Casablanca-H510:~/catkin_ws$ roscd beginner_tutorials
roscd: No such package/stack 'beginner_tutorials'
ahmedadelhekal gravatar image ahmedadelhekal  ( 2017-09-17 07:24:50 -0500 )edit

Can I confirm that you have created the package and ran the commands to build the package as well before sourcing?

surfertas gravatar image surfertas  ( 2017-09-17 07:30:39 -0500 )edit

Have you tried compiling first then sourceing the setup.bash?

jayess gravatar image jayess  ( 2017-09-19 00:11:45 -0500 )edit

could you tell me the command to make compile

ahmedadelhekal gravatar image ahmedadelhekal  ( 2017-09-19 00:17:33 -0500 )edit

catkin_make

jayess gravatar image jayess  ( 2017-09-19 00:37:46 -0500 )edit

2 Answers

Sort by » oldest newest most voted
0

answered 2017-09-16 17:53:18 -0500

jayess gravatar image

updated 2017-10-09 11:58:20 -0500

Welcome! This question comes up quite often. A quick Google search will give you numerous results:

This is just to name the first few results.


Edit:

I noticed that you're sourceing your setup.bash before you compile. Try doing it in this order:

~/catkin_ws/$ catkin_make
~/catkin_ws/$ source devel/setup.bash

Edit 2:

As @jarvisschultz pointed out in the comments:

rospack uses a cache of all available packages. This caches is, in turn, used by tools like roscd. This cache is supposed to be re-built every 60 seconds by default, but sometimes it seems like this fails.
You could force a re-build with rospack profile or you could try removing the cache files in ~/.ros/rospack_cache*. Both of these have helped me in the past when packages couldn't be picked up even though the environment vars were correct.

edit flag offensive delete link more

Comments

thanx but it doesnot work for me

ahmedadelhekal gravatar image ahmedadelhekal  ( 2017-09-17 07:27:19 -0500 )edit

Do you have a package with that name? Did you catkin_make it from the root of your workspace? Did you source the setup.bash? What have you done and what was the result?

jayess gravatar image jayess  ( 2017-09-17 11:03:30 -0500 )edit

ahmed@ahmed-HP-Casablanca-H510:~/catkin_ws$ source devel/setup.bash ahmed@ahmed-HP-Casablanca-H510:~/catkin_ws$ catkin_make Base path: /home/ahmed/catkin_ws Source space: /home/ahmed/catkin_ws/src Build space: /home/ahmed/catkin_ws/build Devel space: /home/ahmed/catkin_ws/devel Install space: /home/

ahmedadelhekal gravatar image ahmedadelhekal  ( 2017-09-17 18:29:24 -0500 )edit

Can you please update your question with that information? It looks like it got cut off due to character count limitations.

jayess gravatar image jayess  ( 2017-09-17 18:55:06 -0500 )edit

rospack uses a cache of all available packages. This caches is, in turn, used by tools like roscd. This cache is supposed to be re-built every 60 seconds by default, but sometimes it seems like this fails.

jarvisschultz gravatar image jarvisschultz  ( 2017-09-18 12:14:33 -0500 )edit

You could force a re-build with rospack profile or you could try removing the cache files in ~/.ros/rospack_cache*. Both of these have helped me in the past when packages couldn't be picked up even though the environment vars were correct.

jarvisschultz gravatar image jarvisschultz  ( 2017-09-18 12:17:05 -0500 )edit
0

answered 2017-09-29 15:47:43 -0500

updated 2017-10-09 06:52:48 -0500

Make sure you have created the package beginner_tutorials on your catkin_ws/src

Something like:

cd ~/catkin_ws/src
catkin_create_pkg beginner_tutorials
rospack profile
roscd beginner_tutorials
edit flag offensive delete link more

Your Answer

Please start posting anonymously - your entry will be published after you log in or create a new account.

Add Answer

Question Tools

1 follower

Stats

Asked: 2017-09-16 16:33:07 -0500

Seen: 2,074 times

Last updated: Oct 09 '17