Ask Your Question
0

cmake fails: Inconsistency detected by ld.so

asked 2017-09-12 12:44:24 -0600

amstrudy gravatar image

updated 2017-09-12 13:01:35 -0600

I recently set up a new Ubuntu 14 VM to install indigo on. I installed indigo, and since I'm working with an Aldebaran Nao humanoid robot, I also downloaded the naoqi SDK. Then, I downloaded these packages: nao_robot, nao_extra, roboticsgroup_gazebo_plugins, pal_msgs, and pal_gazebo_plugins. I tried a catkin_make after this, and got the following error:

Base path: /home/amstrudy/catkin_ws
Source space: /home/amstrudy/catkin_ws/src
Build space: /home/amstrudy/catkin_ws/build
Devel space: /home/amstrudy/catkin_ws/devel
Install space: /home/amstrudy/catkin_ws/install

Running command:

cmake /home/amstrudy/catkin_ws/src -DCATKIN_DEVEL_PREFIX=/home/amstrudy/catkin_ws/devel -DCMAKE_INSTALL_PREFIX=/home/amstrudy/catkin_ws/install -G Unix Makefiles" in "/home/amstrudy/catkin_ws/build"

    Inconsistency detected by ld.so: dl-version.c: 224: _dl_check_map_versions: Assertion `needed != ((void *)0)' failed!
    Invoking "cmake" failed

I uninstalled the packages, commented out the source lines and LD_LIBRARY_PATH and PYTHON_PATH lines in my bashrc (which pointed to stuff in naoqi), deleted and reinstalled indigo, but still no luck. I know that catkin_make worked as some point because I used it to setup my catkin_ws. I've researched around but haven't found a solution.

Thanks.

EDIT: I tried deleting the naoqi SDK from my VM, and voila, cmake (and catkin_make) are both back up and running. I have no idea how this could be? I need naoqi, so any ideas as to how to fix this?

edit retag flag offensive close merge delete

Comments

I edited your question to make it easier to read. I did my best but I feel that I may have mangled it a bit. Feel free to redo it, but please don't use code tags. Just highlight the code/errors/commands and click the 101010 button.

jayess gravatar imagejayess ( 2017-09-12 12:55:37 -0600 )edit

@jayess thank you!

amstrudy gravatar imageamstrudy ( 2017-09-12 13:03:15 -0600 )edit

What does running catkin_make from the root of your workspace give you?

jayess gravatar imagejayess ( 2017-09-12 14:59:46 -0600 )edit

1 Answer

Sort by ยป oldest newest most voted
0

answered 2017-09-12 12:57:39 -0600

jayess gravatar image

Why are you directly invoking cmake? You should be using catkin_make from the root of your workspace.

edit flag offensive delete link more

Comments

I'm not directly invoking cmake, but catkin_make. When I was investigating the error I narrowed the problem down to cmake. Any attempt to use the command results in the above error.

Also, please see my edits above!

amstrudy gravatar imageamstrudy ( 2017-09-12 12:59:49 -0600 )edit

Your Answer

Please start posting anonymously - your entry will be published after you log in or create a new account.

Add Answer

Question Tools

2 followers

Stats

Asked: 2017-09-12 12:44:24 -0600

Seen: 281 times

Last updated: Sep 12 '17