Ask Your Question
1

Python version to use with ROS kinetic

asked 2017-09-09 11:03:17 -0600

bxl gravatar image

updated 2017-09-09 11:06:02 -0600

Which python interpreter version is most advisable to use with ROS kinetic and gazebo 7 simulator? As I read to set up ros to work with python 3 requires a extra effort.

edit retag flag offensive close merge delete

1 Answer

Sort by ยป oldest newest most voted
4

answered 2017-09-09 11:19:18 -0600

marguedas gravatar image

updated 2017-09-09 12:04:24 -0600

ROS kinetic targets Python2.7 (It does recommends compatibility with python 3 but doesn't require it). Gazebo doesn't have a Python interface AFAIK.

You can find more details about what version of languages and dependencies a specific ROS distribution targets on REP3.

Hope this helps

Edit: "As I read to set up ros to work with python 3 requires a extra effort." indeed python3 not being officially supported, none of the packages are tested with python3, thus there is no list of known compatibility problems and the potential of breakage is pretty high. So I'd recommend python2.7 and if you write python code to write it in a way that it can run with both versions

edit flag offensive delete link more

Comments

See also a number of previous questions about this: #q237613 and #q262551 fi.

gvdhoorn gravatar imagegvdhoorn ( 2017-09-09 15:25:26 -0600 )edit

Your Answer

Please start posting anonymously - your entry will be published after you log in or create a new account.

Add Answer

Question Tools

1 follower

Stats

Asked: 2017-09-09 11:03:17 -0600

Seen: 8,736 times

Last updated: Sep 09 '17