ROS Resources: Documentation | Support | Discussion Forum | Index | Service Status | Q&A answers.ros.org
Ask Your Question
0

Roslaunch ERROR: cannot launch node of type [rgbd_launch/hydro-upgrade-notice]

asked 2017-08-30 12:38:42 -0600

cam2998 gravatar image

updated 2017-08-30 17:27:44 -0600

Alright, so I type in

-$ roscore

Then open up a new terminal and change my directory to the folder with the launch file

-$ cd  ~/Downloads/ros_astra_launch-master/launch/includes

Then when I launch the file with

-$ roslaunch device.launch

It then gives me this message

... logging to /home/orbbec/.ros/log/e6e0ff2a-159e-11e0-b86f-1bda0be1e545/roslaunch-orbbec-1302.log
Checking log directory for disk usage. This may take awhile.
Press Ctrl-C to interrupt
Done checking log file disk usage. Usage is <1GB.

started roslaunch server http://orbbec:56226/

SUMMARY
========

PARAMETERS
 * /device_deprecated/from_pkg: openni2_launch
 * /device_deprecated/from_pkg_path: launch/includes/d...
 * /device_deprecated/name: device.launch
 * /device_deprecated/to_pkg: openni2_launch
 * /device_deprecated/to_pkg_path: launch/includes/d...
 * /rosdistro: indigo
 * /rosversion: 1.11.21

NODES
  /
    device_deprecated (rgbd_launch/hydro-upgrade-notice)

ROS_MASTER_URI=http://localhost:11311

core service [/rosout] found
ERROR: cannot launch node of type [rgbd_launch/hydro-upgrade-notice]: rgbd_launch
ROS path [0]=/opt/ros/indigo/share/ros
ROS path [1]=/opt/ros/indigo/share
ROS path [2]=/opt/ros/indigo/stacks
No processes to monitor
shutting down processing monitor...
... shutting down processing monitor complete

Background: I am working with the Persee and have put Indigo on it which has been slightly modified by Orbbec for the persee. I am simply trying to run one of their launch files in the packages that they provide and I am getting this error message. I assume I just don't have a rgbd_launch file and that is why I am getting this message. I tried downloading a rgbd_launch package but it wasn't working. Could someone help provide a link and some instructions, please?

EDIT: I downloaded the rgbd_launch from https://github.com/ros-drivers/rgbd_l... and the ubuntu 14.4 version is from https://3dclub.orbbec3d.com/t/univers... .

After installing I left them in the download folder and did the setup by cding into the package then typing cmake and then make into the terminal. After that I changed directory into where the launch file was and tried launching it with ros launch and it said that it was not in the directory, even though when i type ls, it said it was.

Maybe, I might have just messed up the install. Any different methods, maybe with clear instruction, might work out better for me.

P.S. I am an amatuer when it comes to linux, packages, and cmake files.

edit retag flag offensive close merge delete

Comments

Welcome, but we'll need some more info to help. Where did you get the package from (links are helpful), how did you install it, are you on the correct branch, etc.? Please update your question with the relevant info.

jayess gravatar image jayess  ( 2017-08-30 13:30:18 -0600 )edit

Updated originally post, I can add another edit with specific branches, error messages, and locations of packages tomorrow if it is still unclear how to help me and my situation.

cam2998 gravatar image cam2998  ( 2017-08-30 17:29:26 -0600 )edit

1 Answer

Sort by ยป oldest newest most voted
1

answered 2017-09-03 10:44:27 -0600

130s gravatar image

updated 2017-09-04 22:00:46 -0600

Great amount of effort is made for making package installation less and less painful for ROS.

In your case, assuming you've downloaded source code of the package you want to use along with some more packages you think you need, you may be 1) missing more dependency and/or 2) have incorrectly built some of your packages.

For 1), go to the top directory of your catkin workspace where the packages above are downloaded. E.g. in a lot of tutorials, it is ~/catkin_ws. So cd ~/catkin_ws (if you don't know what catkin workspace, please go back to the basic ROS tutorial). Then run:

rosdep install --from-paths src --ignore-src -r -y

This command magically installs all the packages that packages in catkin workspace depend upon but are missing in your computer (documented on wiki as well).

You seem to be troubled by rgbd_launch you downloaded source code of. But with the steps above, its pre-built binary of that package should be installed so that you wouldn't have to download source and build by yourself, thus you're free from 2).

All assuming that you're on Ubuntu and ROS Indigo.

edit flag offensive delete link more

Your Answer

Please start posting anonymously - your entry will be published after you log in or create a new account.

Add Answer

Question Tools

1 follower

Stats

Asked: 2017-08-30 12:37:48 -0600

Seen: 470 times

Last updated: Sep 04 '17