Ask Your Question
0

mavros offboard no GPS

asked 2017-08-21 16:57:10 -0500

gpldecha gravatar image

updated 2017-08-21 16:57:46 -0500

Hi, have recently been trying to control a rover equipped with a Pixhawk2 in an indoor environment.
For this purpose, I have followed the steps outlined in the mavros_offboard tutorial. I also had to change a few parameters on the PX4 firmware to allow the rover to arm without a GPS lock etc..

After running a script similar to the tutorial one, I was able to switch to offboard mode, see below the echo of topic /mavros/state

header: 
  seq: 3105
  stamp: 
    secs: 1503352094
    nsecs: 242159569
  frame_id: ''
connected: True
armed: True
guided: True
mode: OFFBOARD
system_status: 4

However, the mavros node interfacing with the rover is printing the following output:

[ WARN] [1503352273.909538514]: GP: No GPS fix
[ INFO] [1503352280.350340503]: HP: requesting home position

I have tried to set this position with no success.

If any of you have managed to run a px4/apm robot in an offboard mode with no GPS I would be grateful for information on:

  1. Telling mavros/pixhawk not to expect a GPS fix

  2. Getting the tf topic to publish something (I guess this is related to 1.)

Thanks for any help.

edit retag flag offensive close merge delete

Comments

I definitely could be wrong but I believe that a GPS source is needed (whether it's real or faked).

jayess gravatar imagejayess ( 2017-08-21 18:53:55 -0500 )edit

@jayess, not sure either. I will ask on the px4 forum and see if anybody has an idea.

gpldecha gravatar imagegpldecha ( 2017-08-22 03:29:41 -0500 )edit

1 Answer

Sort by ยป oldest newest most voted
1

answered 2017-10-05 12:55:18 -0500

deksprime gravatar image

Assuming that you have PX4 Firmware somewhere above 1.6.0, you could try to set EKF2_AID_MASK bitmask's least significant bit -which is fuse gps option- to 0 in order to stop fusing GPS. If you're using LPE, you could do a similar thing on its bitmask on LPE_FUSION parameter. You could as well change CBRK_GPSFAIL parameter to 240024 in order for the Pixhawk to ignore checking whether you have GPS receiver or not.

edit flag offensive delete link more

Your Answer

Please start posting anonymously - your entry will be published after you log in or create a new account.

Add Answer

Question Tools

2 followers

Stats

Asked: 2017-08-21 16:57:10 -0500

Seen: 993 times

Last updated: Aug 21 '17