Ask Your Question
0

Imported map resizes and flickers in RViz

asked 2017-08-21 15:30:24 -0500

mewescott gravatar image

updated 2017-08-22 01:40:50 -0500

gvdhoorn gravatar image

Hello, I run Ridgeback robot on RVIZ with nagivation stack. Everything worked fine, I have the robot model in RVIZ and I was able to navigate around and created a map. The problem happened when I tried to use the existing map, the model will keep flickering and the map only show up when i click on reset in RVIZ. Here are the commands and steps that I use to bring out the existing map to RVIZ:

  • Because my navigation stack stored inside the robot, I run these launch files in robot terminal seperately:

In Terminal 1:

source devel/setup.bash
roslaunch ridgeback_navigation odom_navigation_demo.launch

In Terminal 2:

source devel/setup.bash
roslaunch jackal_navigation gmapping.launch

In Terminal 3:

source devel/setup.bash
roslaunch ridgeback_viz view_robot.launch config:=gmapping

In Terminal 4:

roslaunch ridgeback_navigation amcl_demo.launch map_file:=/home/administrator/ridgeback_world.yaml

After that in my laptop terminal.

export ROS_MASTER_URI=http://cpr-r100-0019:11311
export ROS_IP=192.168.0.103
export ROS_HOSTNAME=laura-Precision-M6400/
roslaunch ridgeback_viz view_robot.launch config:=local

*Note that I saved my map files inside the robot, because when i saved it in the laptop, the file won't launch.

It does not seem to matter if we create the map from live data or logged data it does the same thing. If we use the same map on a simulated robot in RViz is shows up and works just fine. Any suggestions? How do we keep the map from resizing. Our current map is 4000 x 4000 and it keeps resizing down to 992 x 992. We tried to use the 2D Nav pose to position the robot within the map. It stops jumping around when it gets close to the actual position but it starts jumping again.

edit retag flag offensive close merge delete

1 Answer

Sort by ยป oldest newest most voted
0

answered 2017-08-22 01:40:19 -0500

gvdhoorn gravatar image

If I read your question text correctly, you appear to be running gmapping even though you already have a map. As far as I know, gmapping is only involved when making a map, not when using one you made earlier.

edit flag offensive delete link more

Your Answer

Please start posting anonymously - your entry will be published after you log in or create a new account.

Add Answer

Question Tools

1 follower

Stats

Asked: 2017-08-21 15:30:24 -0500

Seen: 213 times

Last updated: Aug 22 '17