Ask Your Question
1

Raspberry pi and Teleop

asked 2017-07-22 05:31:05 -0600

StevenCoral gravatar image

updated 2017-07-22 05:35:29 -0600

Hi all, I have been searching for days now to get any keyboard-teleop node to run on my kinetic-jessie-pi system.

None of the apt-get packages are ever found (another forum question says its not possible to install ROS packages using apt-get if i had not installed ros with it in the first place).

I tried installing from source following this link , replacing indigo with kinetic. it downloads the source but trying to install only gives:

ERROR: the following packages/stacks could not have their rosdep keys resolved to system dependencies: rocon_apps: No definition of [rospy_tutorials] for OS version []

and more similar lines for every package. I also tried to clone the git of "teleop_twist_keyboard", put it in my ws, ran catkin_make, sourced setup.bash and ros refuses to find it. When using rosrun from inside the folder, I get a long list of errors.

Tried to create my own node using python, the only viable keyboard listener I could find is from keyboard 0.9.13 which requires sudo privileges, while adding the "sudo" prefix in a launch file results in that the root user cannot find the ros environment variables. Trying to export them through the python script or call an external bash script from within python did not work.

I just want to move my Rpi robot using a wireless keyboard. Does anyone have any idea how to run any keyboard teleop node on a raspberry pi 3?

Many thanks, Steve

edit retag flag offensive close merge delete

1 Answer

Sort by ยป oldest newest most voted
0

answered 2017-07-22 10:32:45 -0600

updated 2017-07-23 06:37:33 -0600

Hello Steve,

In my raspberry pi 3 I have followed this guide:http://wiki.ros.org/ROSberryPi/Installing%20ROS%20Kinetic%20on%20the%20Raspberry%20Pi to install ROS-comm version in Raspbian Jessie.

This version includes only the bare essentials, so many times when I wanted for instanse other packages like URDF or msg, I followed the procedure explained at the bottom of this page.

So for instance, in your case I imagine that something like that will work:

$ cd ~/ros_catkin_ws

$ rosinstall_generator teleop_twist_keyboard --rosdistro kinetic --deps --wet-only --tar > kinetic-custom_ros.rosinstall

$ wstool merge -t src kinetic-custom_ros.rosinstall

$ wstool update -t src

$ rosdep install --from-paths src --ignore-src --rosdistro kinetic -y -r --os=debian:jessie

$ sudo ./src/catkin/bin/catkin_make_isolated --install -DCMAKE_BUILD_TYPE=Release --install-space /opt/ros/kinetic -j1

Yes, I usually use -j1 because in -j4 the rPi3 freezes and I have to reboot.

Hope that will help you.

edit flag offensive delete link more

Comments

1

Thank you very much, I missed that part. Your code is correct with an addition of space between the word "generator" and "teleop". I made the mistake of trying to install the entire turtlebot + turtlebot_apps + rviz, building took forever, and got stuck at some point with every -j except -j1.

StevenCoral gravatar imageStevenCoral ( 2017-07-23 03:08:57 -0600 )edit

Well done Steve, I'm happy that it worked. Enjoy coding!

angelos.p gravatar imageangelos.p ( 2017-07-23 06:36:56 -0600 )edit

Your Answer

Please start posting anonymously - your entry will be published after you log in or create a new account.

Add Answer

Question Tools

1 follower

Stats

Asked: 2017-07-22 05:31:05 -0600

Seen: 447 times

Last updated: Jul 23 '17