Ask Your Question
0

Hi, roscore won't start

asked 2017-07-20 15:14:59 -0500

rg10 gravatar image

updated 2017-08-09 14:58:13 -0500

Roscore (and some launch files) won't start. The command line stays as it is until I hit Ctrl-C.

I read a separate forum that said something could be wrong with etc/hosts , ROS_IP, or ROS_HOSTNAME in the .bashrc. I think this is the case because I needed to edit my .bashrc earlier in order to connect with and control a robot. However, now it seems roscore won't start on the PC.

If you see what the problem is, or have a different idea as to the cause, I would greatly appreciate the help.

Here's my .bashrc:

    enter code here# ~/.bashrc: executed by bash(1) for non-login shells.
# see /usr/share/doc/bash/examples/startup-files (in the package bash-doc)
# for examples

# If not running interactively, don't do anything
case $- in
    *i*) ;;
      *) return;;
esac

# don't put duplicate lines or lines starting with space in the history.
# See bash(1) for more options
HISTCONTROL=ignoreboth

# append to the history file, don't overwrite it
shopt -s histappend

# for setting history length see HISTSIZE and HISTFILESIZE in bash(1)
HISTSIZE=1000
HISTFILESIZE=2000

# check the window size after each command and, if necessary,
# update the values of LINES and COLUMNS.
shopt -s checkwinsize

# If set, the pattern "**" used in a pathname expansion context will
# match all files and zero or more directories and subdirectories.
#shopt -s globstar

# make less more friendly for non-text input files, see lesspipe(1)
[ -x /usr/bin/lesspipe ] && eval "$(SHELL=/bin/sh lesspipe)"

# set variable identifying the chroot you work in (used in the prompt below)
if [ -z "${debian_chroot:-}" ] && [ -r /etc/debian_chroot ]; then
    debian_chroot=$(cat /etc/debian_chroot)
fi

# set a fancy prompt (non-color, unless we know we "want" color)
case "$TERM" in
    xterm-color) color_prompt=yes;;
esac

# uncomment for a colored prompt, if the terminal has the capability; turned
# off by default to not distract the user: the focus in a terminal window
# should be on the output of commands, not on the prompt
#force_color_prompt=yes

if [ -n "$force_color_prompt" ]; then
    if [ -x /usr/bin/tput ] && tput setaf 1 >&/dev/null; then
    # We have color support; assume it's compliant with Ecma-48
    # (ISO/IEC-6429). (Lack of such support is extremely rare, and such
    # a case would tend to support setf rather than setaf.)
    color_prompt=yes
    else
    color_prompt=
    fi
fi

if [ "$color_prompt" = yes ]; then
    PS1='${debian_chroot:+($debian_chroot)}\[\033[01;32m\]\u@\h\[\033[00m\]:\[\033[01;34m\]\w\[\033[00m\]\$ '
else
    PS1='${debian_chroot:+($debian_chroot)}\u@\h:\w\$ '
fi
unset color_prompt force_color_prompt

# If this is an xterm set the title to user@host:dir
case "$TERM" in
xterm*|rxvt*)
    PS1="\[\e]0;${debian_chroot:+($debian_chroot)}\u@\h: \w\a\]$PS1"
    ;;
*)
    ;;
esac

# enable color support of ls and also add handy aliases
if [ -x /usr/bin/dircolors ]; then
    test -r ~/.dircolors && eval "$(dircolors -b ~/.dircolors)" || eval "$(dircolors -b)"
    alias ls='ls --color=auto'
    #alias dir='dir --color=auto'
    #alias vdir='vdir --color=auto'

    alias grep='grep --color=auto'
    alias fgrep='fgrep --color=auto'
    alias egrep='egrep --color=auto'
fi

# some more ...
(more)
edit retag flag offensive close merge delete

Comments

Why did you delete the question? Didn't @SL Remy answer it?

gvdhoorn gravatar imagegvdhoorn ( 2017-08-09 15:21:54 -0500 )edit

1 Answer

Sort by ยป oldest newest most voted
0

answered 2017-07-21 00:19:45 -0500

SL Remy gravatar image

It may be significant that your ros_master_uri is different from your ros_hostname.. the ros_master_uri is saying where the roscore is actually running. So there are couple of questions, are you trying to run roscore remotely? Is your IP address 10.101.151.20?

edit flag offensive delete link more

Comments

You were right, the problem was that my ros_master_uri was different from my ros_hostname. I had switched from using roscore on a separate machine through my computer to on my computer. It's working well now. Thank you!

rg10 gravatar imagerg10 ( 2017-08-02 14:02:39 -0500 )edit

@ronangunning100: if you feel @SL Remy's answer has answered your question, could you please tick the checkmark to the left of his answer? That will clearly mark the question as answered.

Thanks.

gvdhoorn gravatar imagegvdhoorn ( 2017-08-02 14:04:22 -0500 )edit

Thanks @gvdhoorn for the reminder

rg10 gravatar imagerg10 ( 2017-08-07 15:02:41 -0500 )edit

Your Answer

Please start posting anonymously - your entry will be published after you log in or create a new account.

Add Answer

Question Tools

2 followers

Stats

Asked: 2017-07-20 15:14:59 -0500

Seen: 592 times

Last updated: Aug 09 '17