Ask Your Question
0

Gazebo not opening in ROS kinetic and Ubuntu 16.04

asked 2017-07-13 06:11:13 -0500

shyamashi gravatar image

I have installed ros kinetic in Ubuntu 16.04(Xenial) after adding the repos n exactly as said in wiki-ros page(http://wiki.ros.org/kinetic/Installation/Ubuntu). The final step was ""sudo apt-get install ros-kinetic-desktop-full"". In terminal when I run $ gazebo, the gazebo 7 window (yellow color) comes up for a long time and it fails to launch the simulation window. Any mistakes that I am doing? Pls help

edit retag flag offensive close merge delete

Comments

If you'd like help. Please edit your question to include console outputs, the log files for your runs, maybe some screenshots so we can know what's happening on your system. Also please include your platform specifications.

tfoote gravatar imagetfoote ( 2017-07-13 10:40:45 -0500 )edit

2 Answers

Sort by » oldest newest most voted
0

answered 2018-02-24 19:12:47 -0500

Hello I got the same error here Here is the output of the command ( gazebo --verbose):
gazebo --verbose
Gazebo multi-robot simulator, version 7.11.0
Copyright (C) 2012 Open Source Robotics Foundation.
Released under the Apache 2 License.
http://gazebosim.org

[Msg] Waiting for master.
Gazebo multi-robot simulator, version 7.11.0
Copyright (C) 2012 Open Source Robotics Foundation.
Released under the Apache 2 License.
http://gazebosim.org

[Msg] Waiting for master.
[Msg] Connected to gazebo master @ http://127.0.0.1:11345
[Msg] Publicized address: 10.10.0.222
gzserver: symbol lookup error: /usr/lib/x86_64-linux-gnu/libsdformat.so.4: undefined symbol: _ZN8ignition4math15SemanticVersionC1ERKNSt7__cxx1112basic_stringIcSt11char_traitsIcESaIcEEE

edit flag offensive delete link more

Comments

Please post this as a new question. Seeing as this is really a Gazebo problem, please post this over at answers.gazebosim.org.

Also: I don't believe your issue is the same as the one reported by the OP.

gvdhoorn gravatar imagegvdhoorn ( 2018-02-25 05:46:52 -0500 )edit
0

answered 2017-07-14 11:06:35 -0500

updated 2017-07-14 11:06:51 -0500

You could try running Gazebo in verbose mode (gazebo --verbose) to see if any errors are printed out.

The first time you run Gazebo, it may download a couple of models from the internet, so it might take a while depending on your connection.

edit flag offensive delete link more

Comments

fixed - The first time you run Gazebo, it may download a couple of models from the internet, so it might take a while depending on your connection.

caiotfgv gravatar imagecaiotfgv ( 2017-11-07 23:32:00 -0500 )edit

Your Answer

Please start posting anonymously - your entry will be published after you log in or create a new account.

Add Answer

Question Tools

3 followers

Stats

Asked: 2017-07-13 06:11:13 -0500

Seen: 4,866 times

Last updated: Jul 14 '17