ROS Resources: Documentation | Support | Discussion Forum | Index | Service Status | ros @ Robotics Stack Exchange
Ask Your Question

The hector_mapping and move_base can't work together ,but cartographer can.

asked 2017-07-09 08:00:51 -0500

scopus gravatar image

updated 2017-07-19 05:05:31 -0500

Hi , all :

I want to use hector_mapping and move_base to work together on the turtlebot which has a rplidar,but when I shart up move_base to get a path planning, I find move_base continuously print the alarm information,

[ WARN] [1499649044.602318070, 109.050000000]: Control loop missed its desired rate of 3.0000Hz... the loop actually took 3.1000 seconds
[ WARN] [1499649044.602556838, 109.050000000]: Map update loop missed its desired rate of 3.0000Hz... the loop actually took 2.7667 seconds

which leads to the robot path planning is not smooth. The robot dosen't move. I have already reduced update_frequency, publish_frequency of global_costmap and local_costmap. I also decrease the controll frequence of planner in move base. However, move_base still continuously output the warning information. The robot dosen't move a little.

PS: when I only use hector_mapping build a map, everything is ok. who can tell me why move_base print this warn and how to solve this problem ? Thanks.

EDIT·1: I also tried the cartographer-ros and karto with movebase. They all worked fine.

Actually, we have monitored the usage of CPU and memory when running these SLAM packages. We have the order of consumption is cartographer>karto>hector.

So we wonder why the hector mapping with the lowest usage of CPU and memory can't work together with movebase, but cartographer with the highest usage of CPU and meory can!

Hopefully anyone give us any advices!


For experiments in simulator(gazebo), the hardware is with Intel® Core™ i5-6500 CPU @ 3.20GHz × 4 , memory is 15.6 GiB. We thinks such hardware is totally enough for running hector and ftc_local_planner. So it is so weird that the above warning information is output. As I am told from some questions in , this is usually because the CPU power or memory is not enough for running such packages.


We found new situations and asked a new question here, please move to this link. Thanks!

edit retag flag offensive close merge delete

1 Answer

Sort by » oldest newest most voted

answered 2017-07-10 10:49:53 -0500

rong888 gravatar image

Hello,in my opinion,the move_base package work in a different environment.Move_base need the amcl and odom information,but the hector don't approve that.It seems that move_base use a different map message,too. And,how about your hector map?Did it build correctly?I run the hector map with some errors.

edit flag offensive delete link more


hi, the mapping process is without move_base. After a local map( eg. a room) is built, the move_base node is used. We use such combination(we don't use amcl) to implement an online mapping and path planning. Thank you!

scopus gravatar image scopus  ( 2017-07-10 19:59:36 -0500 )edit

We found new situation and asked a new question here, please move to this link. Thanks!

scopus gravatar image scopus  ( 2017-07-18 22:37:38 -0500 )edit

Question Tools



Asked: 2017-07-09 08:00:51 -0500

Seen: 1,229 times

Last updated: Jul 19 '17