Cannot run turtlebot stage simulation

asked 2017-07-06 19:14:40 -0600

UniversityStudent1701 gravatar image

Hello

I am unable to run the turtlebot stage simulation using the command roslaunch turtlebot_stage turtlebot_in_stage.launch. I am using ROS Indigo on Ubuntu 14.04. ROS is working (I tested it by running roscore) and stage seems to be kind of working, but there are problems.

I am aware that this question is similar to the one here: http://answers.ros.org/question/24875... , but the answers there didn't help me.

When I run roslaunch turtlebot_stage turtlebot_in_stage.launch I get the following output:
while processing /opt/ros/indigo/share/turtlebot_navigation/launch/includes/amcl.launch.xml: Invalid roslaunch XML syntax: [Errno 2] No such file or directory: u'/opt/ros/indigo/share/turtlebot_navigation/launch/includes/amcl.launch.xml' The traceback for the exception was written to the log file

To test whether or not stage was working I looked at this website: http://playerstage.sourceforge.net/do... , and tried entering the following command: stage worlds/simple.world.
This opened a stage window that I could pause or unpause, but there were no robots in it, and I got the output: err: unable to open world file worlds/simple.world : No such file or directory

I am trying to learn how to use stage. Any help or advice would be greatly appreciated

edit retag flag offensive close merge delete