ROS Resources: Documentation | Support | Discussion Forum | Index | Service Status | ros @ Robotics Stack Exchange
Ask Your Question

No data when echoing the topics

asked 2017-07-06 07:08:00 -0500

rayane gravatar image

updated 2017-07-06 07:11:02 -0500

hey, guys I'm using Navio+ with Raspberry pi 2 to fly a drone but i have a problem with mavros topics. I tried to echo the topics but I got no data streamed, I tried to run

rosrun mavros mavsys rate --all 10

but still couldn't get any data stream. Any suggestion PLZ!!

edit retag flag offensive close merge delete

1 Answer

Sort by ยป oldest newest most voted

answered 2017-08-20 08:08:47 -0500

Mcskywalker gravatar image

You have to run the launch file first.I have Pixhawk with APM stack. The file is located at /mavros/launch. Will have to change the port names accordingly inside the launch file

roslaunch apm2.launch


rostopic list

edit flag offensive delete link more


Thx for the reply, Now it is working. I stated all over again from burning the image into the SD card and i reinstalled everything. till now i don't know what was the problem

rayane gravatar image rayane  ( 2017-08-20 11:35:21 -0500 )edit

Question Tools



Asked: 2017-07-06 07:08:00 -0500

Seen: 444 times

Last updated: Jul 06 '17