ROS Resources: Documentation | Support | Discussion Forum | Index | Service Status | Q&A
Ask Your Question

orocos-bfl not found when building ROS lunar + Ubuntu 16.04

asked 2017-07-04 12:15:51 -0500

Alexander gravatar image

I am trying to wrap my head around building ROS navigation. I have read as much as I can online, none of the answers posted are a fix and most are a few years out of date.

My robot_pose_ekf CMakeList.txt reads as follows:

 cmake_minimum_required(VERSION 2.8.3)

 pkg_check_modules(BFL REQUIRED orocos-bfl)

 message("BFL include dirs:" ${BFL_INCLUDE_DIRS})
 message("BFL library dirs:" ${BFL_LIBRARY_DIRS})

I have played around with orocos-bfl bfl or BFL or some other permutations to no avail.

I am not confident at all the bfl is even installed. I followed some instructions to install it as it is an independant package but the sources are dead links.

With all the people on a recent install of ubuntu 16.04 trying to get the navigation stack running I can't be the only one with this trouble...

I found this page and I have no idea what it means:

I installed this package but it is just an empty package:

I also tried the following which is a dead link:

Any pointers on installing bfl?

Thank you

edit retag flag offensive close merge delete


Do you have a specific reason for wanting to build it from source?

gvdhoorn gravatar image gvdhoorn  ( 2017-07-04 14:50:33 -0500 )edit

2 Answers

Sort by ยป oldest newest most voted

answered 2018-02-26 19:36:17 -0500

ssr_selvamraju gravatar image

Here's how I solved this:

I seemed to have installations of both kinetic-bfl and lunar-bfl, despite updating my ros version to lunar. So I went back and removed all installations of bfl.

apt-get remove ros-kinetic-bfl ros-lunar-bfl

Then had to clear the cmake cache in my catkin workspace:

catkin_make clean
rm -rf build/

Now running catkin_make in my workspace that had the robot_pose_ekf package, went through just fine.

OS Version: Ubuntu 16.04.3 LTS ROS Version: Lunar

This line needs to read orocos-bfl (as below) and not just bfl (as in the roswiki)

pkg_check_modules(BFL REQUIRED orocos-bfl)
edit flag offensive delete link more

answered 2017-07-04 12:26:02 -0500

Alexander gravatar image

updated 2017-07-04 12:50:08 -0500

I think I may have solved this with the following:

Download source from here: (I chose version 8).

Unzip this source code into your catkin_ws/src folder .

Get the package.xml from here: (you just need the file that matches your ros version (lunar for me)

Put the package.xml into the orcos source code folder in above.

Open package.xml and change the version number to 0.8.0 if that is what you downloaded.

catkin_make will not work, it will complain about the existence of some non-catkin cmake stuff.

You will have to use catkin_make_isolated

For me this yields the following but it looks like a different error bfl may be compiling successfully.:

Could not find a package configuration file provided by "move_base_msgs"
  with any of the following names:


  Add the installation prefix of "move_base_msgs" to CMAKE_PREFIX_PATH or set
  "move_base_msgs_DIR" to a directory containing one of the above files.  If
  "move_base_msgs" provides a separate development package or SDK, be sure it
  has been installed.

Which is no fun because move_base is in the navigation package.

edit flag offensive delete link more


Thank you for the help. I have followed your instructions, but now cmake is not recognizing some commands in the CMakeLists.txt files. It is not recognizing GLOBAL_ADD_INCLUDE, or GLOBAL_ADD_INCLUDE_DIR. Do you know what the issue is here? I even updated my version of cmake to the latest version 3.9

Raisintoe gravatar image Raisintoe  ( 2017-07-05 13:08:02 -0500 )edit

Your Answer

Please start posting anonymously - your entry will be published after you log in or create a new account.

Add Answer

Question Tools

1 follower


Asked: 2017-07-04 12:15:51 -0500

Seen: 1,486 times

Last updated: Feb 26 '18