Ask Your Question
0

can not roslauunch Turtlebot in Docker container

asked 2017-06-29 20:18:35 -0500

Eric_ROS gravatar image

Hello~ all

I create a docker to quickly setup ROS-indigo and Turtlebot packages on Ubuntu. I have Turtlebot PC and Remote PC. After testing, this docker works well on Remote PC to interact with Turtlebot PC. But unfortunately , if I run this docker on my Turtlebot PC, it's failed and shows some Error messages.

[ERROR] [1498784075.788970033]: Zeroconf: failed to create an avahi client.
zeroconf: client.c:785: avahi_client_get_state: Assertion `client' failed.
[zeroconf/zeroconf-13] process has died [pid 499, exit code -6, cmd /opt/ros/indigo/lib/zeroconf_avahi/zeroconf      
__name:=zeroconf __log:=/root/.ros/log/ae0eabf0-5d2e-11e7-a39a-0242ac110001/zeroconf-zeroconf-13.log].

does anybody know how to solve this ?? Thank you


After running "roslaunch turtlebot_bringup minimal.launch", the error message is shown as follows:

auto-starting new master
process[master]: started with pid [322]
ROS_MASTER_URI=http://172.17.0.1:11311

setting /run_id to ae0eabf0-5d2e-11e7-a39a-0242ac110001
process[rosout-1]: started with pid [335]
started core service [/rosout]
process[robot_state_publisher-2]: started with pid [353]
process[diagnostic_aggregator-3]: started with pid [354]
process[mobile_base_nodelet_manager-4]: started with pid [355]
process[mobile_base-5]: started with pid [356]
process[bumper2pointcloud-6]: started with pid [357]
process[cmd_vel_mux-7]: started with pid [358]
process[turtlebot_laptop_battery-8]: started with pid [359]
process[capability_server-9]: started with pid [360]
process[app_manager-10]: started with pid [421]
process[master-11]: started with pid [436]
process[interactions-12]: started with pid [468]
process[zeroconf/zeroconf-13]: started with pid [499]

[ERROR] [1498784075.788970033]: Zeroconf: failed to create an avahi client.

zeroconf: client.c:785: avahi_client_get_state: Assertion `client' failed.


[zeroconf/zeroconf-13] process has died [pid 499, exit code -6, cmd /opt/ros/indigo/lib/zeroconf_avahi/zeroconf      
__name:=zeroconf __log:=/root/.ros/log/ae0eabf0-5d2e-11e7-a39a-0242ac110001/zeroconf-zeroconf-13.log].
log file: /root/.ros/log/ae0eabf0-5d2e-11e7-a39a-0242ac110001/zeroconf-zeroconf-13*.log
edit retag flag offensive close merge delete

2 Answers

Sort by ยป oldest newest most voted
0

answered 2017-07-03 06:23:07 -0500

jcerruti gravatar image

Eric,

As you saw in http://answers.ros.org/question/20372... , the issue is that Zeroconf doesn't work in Docker. You can Google for "zeroconf docker" to find solutions for this issue, or use the patch to rocon that Jihoon posted on the other question to modify the concert to not use docker. Unfortunately either solution will require you to search, learn and work a little to make it work.

Good luck! Julian

edit flag offensive delete link more
0

answered 2018-06-21 13:34:15 -0500

vinit_sarode gravatar image

updated 2018-06-21 13:34:39 -0500

Just check if the avahi package is installed or not. If it is not installed try the following link: [ http://www.linuxfromscratch.org/blfs/... ]

If it is installed then do following: cd ~/ sudo /etc/init.d/avahi-daemon start

That's all it will work. Do roslaunch turtlebot_bringup minimal.launch/

edit flag offensive delete link more

Your Answer

Please start posting anonymously - your entry will be published after you log in or create a new account.

Add Answer

Question Tools

2 followers

Stats

Asked: 2017-06-29 20:18:35 -0500

Seen: 332 times

Last updated: Jun 21 '18