Ask Your Question
0

IP camera image not showing up even though image status OK, but image is not found

asked 2017-06-29 07:08:12 -0600

ktg55 gravatar image

Running ROS Kinetic on Ubuntu 16.04 Virtual Machine. Need to run node nerian_sp1, RVIZ seems to be running correctly but no image shows up when connected via Ethernet from IP camera. See warning when I try to run node nerian_sp1, but still shows up when I run rosnode list. Verified Bridged adapter working correctly, can ping my Windows 7 host from Ubuntu guest. Browser in Ubuntu shows camera image so I know it's working

Tried enabling 3D acceleration but caused system to become unstable enabled Virtualization so now the graphics adapter is listed as InnoTek Systemberatung GmbH: Virtual Box Graphics Adapter This device is not working - Using x86 virtualization solution - x11 guest utilities from virtualbox-guest-x11 (proprietary) - Do not use this device (checked) When I check the first bullet and hit Apply Changes, it just defaults back to "Do not use this device".

I was thinking the issue might be the graphics adapter but I do not know how to fix it and otherwise browsing the internet, pictures show up fine and videos play.

katie@katie-VirtualBox:~$ env | grep ROS
ROS_ROOT=/opt/ros/kinetic/share/ros
ROS_PACKAGE_PATH=/opt/ros/kinetic/share
ROS_MASTER_URI=http://localhost:11311
ROSLISP_PACKAGE_DIRECTORIES=
ROS_DISTRO=kinetic
ROS_ETC_DIR=/opt/ros/kinetic/etc/ros

katie@katie-VirtualBox:~$ rviz -l
[ INFO] [1498674668.815815723]: rviz version 1.12.10
[ INFO] [1498674668.815964556]: compiled against Qt version 5.5.1
[ INFO] [1498674668.816015134]: compiled against OGRE version 1.9.0 (Ghadamon)

katie@katie-VirtualBox:~$ roscore
... logging to /home/katie/.ros/log/8dc3ef80-5c30-11e7-9570-08002792e198/roslaunch-katie-VirtualBox-3525.log
Checking log directory for disk usage. This may take awhile.
Press Ctrl-C to interrupt
Done checking log file disk usage. Usage is <1GB.

started roslaunch server http://katie-VirtualBox:41807/
ros_comm version 1.12.7


SUMMARY
========

PARAMETERS
 * /rosdistro: kinetic
 * /rosversion: 1.12.7

NODES

auto-starting new master
process[master]: started with pid [3537]
ROS_MASTER_URI=http://katie-VirtualBox:11311/

setting /run_id to 8dc3ef80-5c30-11e7-9570-08002792e198
process[rosout-1]: started with pid [3550]
started core service [/rosout]




katie@katie-VirtualBox:~$ rosrun nerian_sp1 nerian_sp1_node
[ WARN] [1498674946.954273774]: No camera calibration file configured. Cannot publish detailed camera information!
Illegal instruction (core dumped)

katie@katie-VirtualBox:~$ rosnode list
/nerian_sp1
/rosout
/rviz_1498675036034260748




katie@katie-VirtualBox:~$ rosrun rviz rviz
[ INFO] [1498675036.010960698]: rviz version 1.12.10
[ INFO] [1498675036.011093630]: compiled against Qt version 5.5.1
[ INFO] [1498675036.011139950]: compiled against OGRE version 1.9.0 (Ghadamon)
[ INFO] [1498675046.303356781]: Stereo is NOT SUPPORTED
[ INFO] [1498675046.303741288]: OpenGl version: 3 (GLSL 1.3).


katie@katie-VirtualBox:~$ rosrun image_view image_view image:=/nerian_sp1/disparity_map
init done
[ INFO] [1498675175.049508491]: Using transport "raw"

katie@katie-VirtualBox:~$ gcc -v
Using built-in specs.
COLLECT_GCC=gcc
COLLECT_LTO_WRAPPER=/usr/lib/gcc/x86_64-linux-gnu/5/lto-wrapper
Target: x86_64-linux-gnu
Configured with: ../src/configure -v --with-pkgversion='Ubuntu 5.4.1-2ubuntu1~16.04' --with-bugurl=file:///usr/share/doc/gcc-5/README.Bugs --enable-languages=c,ada,c++,java,go,d,fortran,objc,obj-c++ --prefix=/usr --program-suffix=-5 --enable-shared --enable-linker-build-id --libexecdir=/usr/lib --without-included-gettext --enable-threads=posix --libdir=/usr/lib --enable-nls --with-sysroot=/ --enable-clocale=gnu --enable-libstdcxx-debug --enable-libstdcxx-time=yes --with-default-libstdcxx-abi=new --enable-gnu-unique-object --disable-vtable-verify --enable-libmpx --enable-plugin --with-system-zlib --disable-browser-plugin --enable-java-awt=gtk --enable-gtk-cairo --with-java-home=/usr/lib/jvm/java-1 ...
(more)
edit retag flag offensive close merge delete

1 Answer

Sort by ยป oldest newest most voted
0

answered 2017-06-29 07:14:38 -0600

gvdhoorn gravatar image

updated 2017-06-29 07:15:18 -0600

ROS programs with GUIs involved (ie: RViz, Gazebo, etc) never really work very well for me in virtual machines. It can probably be done, but it's always more work than it's worth to me.

But in this case, I think the following is your problem:

katie@katie-VirtualBox:~$ rosrun nerian_sp1 nerian_sp1_node
[ WARN] [1498674946.954273774]: No camera calibration file configured. Cannot publish detailed camera information!

Illegal instruction (core dumped)

Ignoring the warning, the next line ("illegal instruction") shows that the node has most likely crashed. This means that even if everything else works as it should, nerian_sp1_node is not there any more, hence no images received.

See warning when I try to run node nerian_sp1, but still shows up when I run rosnode list

The fact that the node still shows in the output of rosnode list is probably because of the sudden crash of the node. Try running rosnode cleanup after the node has crashed and then do a rosnode list again.

edit flag offensive delete link more

Your Answer

Please start posting anonymously - your entry will be published after you log in or create a new account.

Add Answer

Question Tools

Stats

Asked: 2017-06-29 07:08:12 -0600

Seen: 201 times

Last updated: Jun 29 '17