ueye node not publishing image messages 2

asked 2017-06-27 12:18:09 -0500

varun1407 gravatar image

updated 2017-06-28 04:11:07 -0500

I am trying to implement LSD SLAM using UI-1221LE-M-GL.

#[ WARN] [1498582927.697497827]: Loaded uEye SDK 4.82.16. Expecting 4.60.5. #[ INFO] [1498582927.698806226]: Found 1 uEye camera. #[ INFO] [1498582927.949965618]: Opened camera UI122xLE-M 4102718110 #[ WARN] [1498582928.158007664]: Failed to load intrinsics for camera from file

I obtain this error when I try rosrun ueye camera. And also I am not able to find anything in rostopic List /rosout /rosout_agge

Above are the nodes which appear. I am using Ros indigo and linux 14.04 LTS. The daemon is also running. Also I tried to find the IDS software suite version 4.60.5 but currently only the new version 4.82.2 is available.

Kindly suggest the steps required to resolve the error or any other sources which can provide the correct procedure.

edit retag flag offensive close merge delete

Comments

What error message do you see?
Does the camera work outside of ROS with ueye_demo?
Have you tried all of the drivers? ueye and ueye_cam

kmhallen gravatar imagekmhallen ( 2017-06-27 12:43:02 -0500 )edit

Thanks for the response. I have edited the question with the error msg. yes the camera works outside ros in ueye_demo. I have tried both the drivers and the result is same.

varun1407 gravatar imagevarun1407 ( 2017-06-28 04:12:43 -0500 )edit

Can you see images with image_view?
The intrinsics must be generated with something like camera_calibration.

kmhallen gravatar imagekmhallen ( 2017-06-28 09:14:01 -0500 )edit

When I use image_view i get a blank window. To calibrate the camera I need the camera live and running. I am not able to achieve that. And also rostopic list does not show the camera topics published. rostopic echo /camera/camerainfo WARNING: topic [/camera/camerainfo] does not appear to be publish

varun1407 gravatar imagevarun1407 ( 2017-06-28 09:24:12 -0500 )edit

Maybe it's helpful to use the IDS tool first. This will help you to set the parameters and get the camera working. You get it here https://en.ids-imaging.com/download-ueye-lin64.html for the most OS.

matt_do gravatar imagematt_do ( 2017-08-11 07:22:31 -0500 )edit