Ask Your Question
0

Integrating Gazebo and MoveIt for trajectory execution for YuMi

asked 2017-06-26 10:38:27 -0500

amuni gravatar image

updated 2017-06-27 08:34:22 -0500

Hi,

I am in the process of integrating Gazebo to view the trajectory generated by MoveIt! for ABB YuMi robot in ROS Kinetic.

I am using these packages as a starting point: https://github.com/OrebroUniversity/yumi

Apart from the two controllers.yaml files, [ https://github.com/OrebroUniversity/y... and https://github.com/OrebroUniversity/y... ]

I have the controllers for Gazebo and the overall graph that can be found here: https://drive.google.com/drive/folder...

As seen from the graph, the FollowJointTrajectory Action is not attached to either Gazebo or MoveIt.

I am trying to better understand the implementation of various controller configurations.

What do I need to add/change so that the FollowJointTrajectory action interface receives the planned trajectory from MoveIt and sends it to Gazebo?

edit retag flag offensive close merge delete

Comments

@amuni: could you please attach the screenshot of rqt_graph to your question? I've given you enough karma for that.

gvdhoorn gravatar image gvdhoorn  ( 2017-06-27 08:36:45 -0500 )edit

@amuni: I'm working on similar problem(moveit gazebo integration for trajectory execution for panda robot). I tried to make sense from this questions and it's helpful. I'm still having some problems. I would like to request you if can share link of your git repository which i can refer to? Thanks.

mvish7 gravatar image mvish7  ( 2018-11-30 07:56:33 -0500 )edit

1 Answer

Sort by ยป oldest newest most voted
0

answered 2017-06-27 07:37:53 -0500

v4hn gravatar image

I can't access your graph without a google account. Please post it publicly.

What do I need to add/change so that the FollowJointTrajectory action interface receives the planned trajectory from MoveIt and sends it to Gazebo?

In your moveit configuration the controller is configured to listen on a ROS action in

/left_arm/joint_trajectory_action/{goal,cancel,feedback...}

So if this is not the topic defined for the gazebo controllers to listen on, then you will have to change either the moveit configuration or the gazebo configuration to match the other one.

edit flag offensive delete link more

Comments

Thanks for the reply. Just made the files public. I will also double check the controller configurations.

amuni gravatar image amuni  ( 2017-06-27 07:54:33 -0500 )edit

I get the following error while launching controllers: [ERROR] [1498569385.724952352, 15.067000000]: Action client not connected: left_arm/joint_trajectory_action [ERROR] [1498569418.091922119, 30.136000000]: Action client not connected: right_arm/joint_trajectory_action

amuni gravatar image amuni  ( 2017-06-27 08:32:26 -0500 )edit

Yes, you get this error because moveit expects the FollowJointTrajectory action server to be available at right_arm/joint_trajectory_action, but there is no action server running there.

You have a FollowJointTrajectory server running at yumi/joint_trajectory_pos_controller/follow_joint_trajectory

v4hn gravatar image v4hn  ( 2017-06-27 08:45:29 -0500 )edit

though, is this the one that can controll the right arm? In this case just change the name in the moveit controllers file from name: "right_arm" to name: "yumi/joint_trajectory_pos_controller" instead. (or change the gazebo controller name to "right_arm"

v4hn gravatar image v4hn  ( 2017-06-27 08:47:50 -0500 )edit

I changed the names of controllers for Gazebo to match the moveIt ones but I still get the same error. I now have an additional error: [ERROR] [1498573871.290679059, 23.978000000]: Unable to connect to move_group action server 'move_group' within allotted time (30s) --Uploaded new files on same link

amuni gravatar image amuni  ( 2017-06-27 09:38:31 -0500 )edit

So turns out I was launching the wrong controllers file from moveit_controller_manager. It's working now. Thanks again for your help.

amuni gravatar image amuni  ( 2017-06-27 10:30:40 -0500 )edit

Your Answer

Please start posting anonymously - your entry will be published after you log in or create a new account.

Add Answer

Question Tools

2 followers

Stats

Asked: 2017-06-26 10:38:27 -0500

Seen: 774 times

Last updated: Jun 27 '17