Turtlebot Basic Gazebo example not working on Kinetic

asked 2017-06-23 09:38:37 -0600

cpa gravatar image

updated 2017-06-24 07:53:30 -0600

gvdhoorn gravatar image

I use Ubuntu MATE 16.04 and try getting started with the turtlebot simulation. I am sure I installed all necessary packages and sourced the environment properly. I tried many tutorials but without success:

Most of the tutorials are for Indigo, but I suppose they should also work in Kinetic. I moved from running the system in VirtualBox to a fresh, native installation. The only thing that worked is driving around.

But gmapping causes the following gazebo error:

gzserver: /build/ogre-1.9-mqY1wq/ogre-1.9-1.9.0+dfsg1/OgreMain/src/OgreRenderSystem.cpp:546: virtual void Ogre::RenderSystem::setDepthBufferFor(Ogre::RenderTarget*): Assertion `bAttached && "A new DepthBuffer for a RenderTarget was created, but after creation" "it says it's incompatible with that RT"' failed.
Aborted (core dumped)
[gazebo-2] process has died [pid 32302, exit code 134, cmd /opt/ros/kinetic/lib/gazebo_ros/gzserver -e ode /opt/ros/kinetic/share/turtlebot_gazebo/worlds/playground.world

I tried this for quite some time and I would be very happy if someone can help me getting started with these basic examples.


Edit:

Can anyone please confirm Gazebo working on Ubuntu MATE 16.04? Executing the following commands throws the mentioned error:

roslaunch turtlebot_gazebo turtlebot_world.launch
roslaunch turtlebot_rviz_launchers view_robot.launch

Now activate the "DepthCloud". After a few seconds the error message appears in the console.

edit retag flag offensive close merge delete

Comments

[..] but I suppose they should also work in Kinetic

well, that is not necessarily true, as you are finding out. For one thing: Gazebo on Indigo is 2.x, while Gazebo on Kinetic is 7.x by default (see also REP 3). Judging from a nr of questions here on ..

gvdhoorn gravatar imagegvdhoorn ( 2017-06-24 07:56:22 -0600 )edit
1

.. ROS Answers, there could be compatibility issues between Gazebo 7.x and the turtlebot simulation package(s) and / or specific Gazebo ROS plugins.

Perhaps you could take a look at the issue trackers for turtlebot and gazebo_ros_pkgs and see whether there are any known problems.

gvdhoorn gravatar imagegvdhoorn ( 2017-06-24 07:57:05 -0600 )edit

Thanks for this information.

cpa gravatar imagecpa ( 2017-06-24 08:04:29 -0600 )edit
1

Were you able to fix the issue?

ash_100 gravatar imageash_100 ( 2017-10-04 15:03:30 -0600 )edit