Ask Your Question
0

invalid master URI

asked 2017-06-20 10:24:13 -0600

SubMarIN gravatar image

updated 2017-06-20 10:25:57 -0600

Hi, I am using the intel euclid vision system for my research, which has ros running on it by default on booting and it has a web interface. By mistake, i changed the ROS_MASTER_URI on the web interface and after a reboot, nothing is running. When I ssh into the device and run roscore by myself, I see the following error:

invalid master URI: http://http://localhost:11311:11311/ The traceback for the exception was written to the log file

Clearly the ROS_MASTER_URI is wrong but I dont know where to change it again because putting the correct one in the bashrc also doesnt allow roscore to run by default on booting. Is there any place, other than the bashrc where the ROS_MASTER_URI can be set? Please me help with this issue! Since the ROS_MASTER_URI is set wrong, I am unable to reacess the web interface aswell!

edit retag flag offensive close merge delete

1 Answer

Sort by ยป oldest newest most voted
0

answered 2017-06-20 11:36:55 -0600

Grover1 gravatar image

You could modify the ROS_MASTER_URI from $sudo vi /etc/hosts This could be useful: https://github.com/mktk1117/six_wheel...

edit flag offensive delete link more

Your Answer

Please start posting anonymously - your entry will be published after you log in or create a new account.

Add Answer

Question Tools

1 follower

Stats

Asked: 2017-06-20 10:24:13 -0600

Seen: 2,708 times

Last updated: Jun 20 '17