ROS Resources: Documentation | Support | Discussion Forum | Index | Service Status | ros @ Robotics Stack Exchange
Ask Your Question

rosserial_arduino with Arduino 1.8.3 [closed]

asked 2017-06-20 09:47:39 -0500

burtbick gravatar image

I was going to build the Arduino code on my new installation of Linux Mint 18.1 and ROS Kinetic following the details on the rosserial_arduino wiki page. But the IDE refused to show the new library in the list of examples and, in addition, was unable to find ros.h when attempting to build.

I downloaded Arduino 1.0.6 and that works fine to build the rosserial Arduino code. I don't see any mention of a specific Arduino IDE in the rosserial tutorial.

Has anyone tried building with the latest Arduino IDE, and if so what did you change to get things to build.

Thanks, Burt

edit retag flag offensive reopen merge delete

Closed for the following reason the question is answered, right answer was accepted by burtbick
close date 2017-10-02 09:50:31.514386

1 Answer

Sort by ยป oldest newest most voted

answered 2017-09-30 19:00:30 -0500

rreignier gravatar image

Just tested with Arduino 1.8.4, everything is OK.

Maybe you could explain your setup a bit more.

edit flag offensive delete link more


Nothing special. As stated Linux Mint 18.1 with Arduino 1.8.3 I notice that you said that it works fine with Arduino 1.8.4 IDE, so I'll go download, install and test with 1.8.4 perhaps it was something specific with Arduino IDE 1.8.3


burtbick gravatar image burtbick  ( 2017-10-01 08:48:28 -0500 )edit

Just had a chance to download and test Arduino IDE 1.8.4 and that does work fine with rosserial so must have been something with the 1.8.3 IDE installation, at least on my system.

burtbick gravatar image burtbick  ( 2017-10-01 12:49:32 -0500 )edit

Ok, great. Please, mark your question as solved.

rreignier gravatar image rreignier  ( 2017-10-01 12:53:26 -0500 )edit

I must be blind, don't see a mark as solved option. Do I just Close the question to mark as solved? Thanks,

burtbick gravatar image burtbick  ( 2017-10-01 13:01:35 -0500 )edit

Ah, under the rate of an answer (up and down arrows), there is a "v" mark to mark an answer as a solution, so the question become answered. But in that particular case, I did not answer your response so closing was the best thing to do I think.

rreignier gravatar image rreignier  ( 2017-10-09 14:08:52 -0500 )edit

Question Tools

1 follower


Asked: 2017-06-20 09:47:39 -0500

Seen: 225 times

Last updated: Sep 30 '17