ROS Resources: Documentation | Support | Discussion Forum | Index | Service Status | ros @ Robotics Stack Exchange
Ask Your Question

OSError: [Errno 13] Permission denied [closed]

asked 2017-06-20 08:44:01 -0500

Yogi_4 gravatar image

updated 2017-06-20 23:59:55 -0500

Traceback (most recent call last): File "/opt/ros/indigo/lib/python2.7/dist-packages/roslaunch/", line 307, in main p.start()

File "/opt/ros/indigo/lib/python2.7/dist-packages/roslaunch/", line 268, in start self._start_infrastructure()

File "/opt/ros/indigo/lib/python2.7/dist-packages/roslaunch/", line 217, in _start_infrastructure self._load_config()

File "/opt/ros/indigo/lib/python2.7/dist-packages/roslaunch/", line 132, in _load_config roslaunch_strs=self.roslaunch_strs, verbose=self.verbose)

File "/opt/ros/indigo/lib/python2.7/dist-packages/roslaunch/", line 451, in load_config_default loader.load(f, config, verbose=verbose)

File "/opt/ros/indigo/lib/python2.7/dist-packages/roslaunch/", line 746, in load self._load_launch(launch, ros_config, is_core=core, filename=filename, argv=argv, verbose=verbose)

File "/opt/ros/indigo/lib/python2.7/dist-packages/roslaunch/", line 718, in _load_launch self._recurse_load(ros_config, launch.childNodes, self.root_context, None, is_core, verbose)

File "/opt/ros/indigo/lib/python2.7/dist-packages/roslaunch/", line 662, in _recurse_load self._param_tag(tag, context, ros_config, verbose=verbose)

File "/opt/ros/indigo/lib/python2.7/dist-packages/roslaunch/", line 95, in call return f(args, *kwds)

File "/opt/ros/indigo/lib/python2.7/dist-packages/roslaunch/", line 264, in _param_tag value = self.param_value(verbose, name, ptype, *vals)

File "/opt/ros/indigo/lib/python2.7/dist-packages/roslaunch/", line 489, in param_value p = subprocess.Popen(shlex.split(command), stdout=subprocess.PIPE)

File "/usr/lib/python2.7/", line 710, in __init__ errread, errwrite)

File "/usr/lib/python2.7/", line 1327, in _execute_child raise child_exception

OSError: [Errno 13] Permission denied

I created a basic urdf model as mentioned in the tutorials and wrote a launch file to view the urdf in rviz When i try to launch file using roslauch i get this error


<arg name="model"/> <node name="rviz" pkg="rviz" type="rviz" args="-d $(find mastering_ ros_robot_description_pkg)/urdf.rviz" required="true"/> </launch>

edit retag flag offensive reopen merge delete

Closed for the following reason the question is answered, right answer was accepted by Yogi_4
close date 2017-09-01 23:56:34.063587


Some context is needed for people to help. Please see the guidelines for asking a question here.

Airuno2L gravatar image Airuno2L  ( 2017-06-20 10:08:55 -0500 )edit

I have updated my question.Thank you!

Yogi_4 gravatar image Yogi_4  ( 2017-06-20 10:26:46 -0500 )edit

Please also post the launch file (and format it with the 0101 button) and tell us which OS and version of ROS you have.

ufr3c_tjc gravatar image ufr3c_tjc  ( 2017-06-20 17:32:03 -0500 )edit

@Yogi_4: I don't see an answer to your problem here, but you have closed the question. If you've solved it by yourself, please post an answer telling us what you did and accept that. If you haven't solved it, then I don't think you should close it as answered.

gvdhoorn gravatar image gvdhoorn  ( 2017-06-21 01:35:29 -0500 )edit

1 Answer

Sort by ยป oldest newest most voted

answered 2017-06-21 02:30:40 -0500

Yogi_4 gravatar image

@ufr3c_tjc I have deleted the package and created the same again.I have re-written the same launch file and it worked.

edit flag offensive delete link more

Question Tools

1 follower


Asked: 2017-06-20 08:44:01 -0500

Seen: 1,856 times

Last updated: Jun 20 '17