Ask Your Question
0

Invalid roslaunch XML syntax: [Errno 2] while running a roslaunch launch file

asked 2017-06-07 09:56:14 -0500

mavrec gravatar image

updated 2018-11-28 23:12:42 -0500

Basically like the title refers on using this command:

roslaunch a1 a1.launch

This is the appearing the error in terminal :

while processing /opt/ros/kinetic/share/turtlebot_navigation/launch/includes/gmapping.launch.xml: Invalid roslaunch XML syntax: [Errno 2] No such file or directory: u'/opt/ros/kinetic/share/turtlebot_navigation/launch/includes/gmapping.launch.xml' The traceback for the exception was written to the log file

Of course I manually looked for the file and found it there in the normal directory, I checked my a1.launch file and my include syntax looks like in order aswel:

include file="$(find turtlebot_navigation)/launch/includes/gmapping.launch.xml"

It goes without saying that I am a complete amateur in all this, I've shown some interest in a robotics internship and am required to know basics and all.

Thanks in advance!!

edit retag flag offensive close merge delete

1 Answer

Sort by ยป oldest newest most voted
2

answered 2017-06-07 10:17:05 -0500

Thomas D gravatar image

The repository shows that the file you are (probably) looking for is at a different path: you are missing a gmapping/ string in the include. So, in your a1.launch file you should change the line you have to:

<include file="$(find turtlebot_navigation)/launch/includes/gmapping/gmapping.launch.xml"/>

Instead of going to the repository online you could also use roscd turtlebot_navigation and find the path to the file you wish to include from your local filesystem.

edit flag offensive delete link more

Comments

Works like a charm, thanks a lot!

mavrec gravatar image mavrec  ( 2017-06-07 10:40:11 -0500 )edit
2

@mavrec: please accept the answer by @Thomas D by ticking the checkmark to the left of his answer.

gvdhoorn gravatar image gvdhoorn  ( 2017-06-08 00:48:39 -0500 )edit

Does one have to re-compile after adding this (And how do you do that?). I added it but it doesn't seem to recognize the change. EDIT: Disregard

ahumay gravatar image ahumay  ( 2019-02-11 22:46:18 -0500 )edit

@ahumay: so did it work for you in the end? If so: what did you change? Or was something else not working?

gvdhoorn gravatar image gvdhoorn  ( 2019-02-12 02:50:15 -0500 )edit

@gvdhoorn yes, I just rebooted my machine

ahumay gravatar image ahumay  ( 2019-02-12 14:57:09 -0500 )edit

Your Answer

Please start posting anonymously - your entry will be published after you log in or create a new account.

Add Answer

Question Tools

1 follower

Stats

Asked: 2017-06-07 09:56:14 -0500

Seen: 3,273 times

Last updated: Nov 28 '18