joy_node is missing in /opt/ros/indigo/share/joy

asked 2017-05-30 02:36:52 -0500

fj138696 gravatar image

hello everyone

I have a very newbie question to ask regarding the joystick driver. I followed this tutorial but when I run the command

 rosrun joy joy_node

i could get this error message

[rosrun] Couldn't find executable named joy_node below /opt/ros/indigo/share/joy

is there any step where i can install the joy_node in share folder? when I search manually in ros folder i could find it /opt/ros/indigo/lib/joy then i tried

sensor@sensor:/$ rosrun /opt/ros/indigo/lib/joy joy_node

but still could not locate the package and the error i got is

[rospack] Error: package '/opt/ros/indigo/lib/joy' not found
find: cannot search `': No such file or directory
[ INFO] [1496129322.616930480]: Opened joystick: /dev/input/js0. deadzone_: 0.050000.

i think i am missing alot of things to set up. I hope someone could help.

edit retag flag offensive close merge delete

Comments

Have you sourced the terminal you are running the commands from? Managing_Your_Environment - oh no, the question is ancient.

Reamees gravatar imageReamees ( 2018-11-21 03:11:50 -0500 )edit