Overlaying workspace gone wrong

asked 2017-05-23 05:17:57 -0600

scHoolhat gravatar image

updated 2017-05-30 03:57:21 -0600

Hello,

On Raspbian Jessie, I created a package cv_bridge_tutorial_pkg and built the workspace using sudo ./src/catkin/bin/catkin_make_isolated --install -DCMAKE_BUILD_TYPE=Release --install-space /opt/ros/indigo -j2. The executable node image_cv_converter_node is in the devel_isolated folder in the package.

When I ran:

rosrun cv_bridge_tutorial_pkg image_cv_converter_node

This is what i get

[rosrun] Couldn't find executable named image_cv_converter_node below /opt/ros/indigo/share/cv_bridge_tutorial_pkg

In my bashrc file, i have sourced:

source /opt/ros/indigo/setup.bash

source /home/pi/ros_catkin_ws/devel_isolated/setup.bash

I checked with echo $ROS_PACKAGE_PATH and it outputs

/home/pi/ros_catkin_ws/src/usb_cam: opt/ros/indigo/share: opt/ros/indigo/stacks

usb_cam is a package taken from the ROS ecosystem. I don't understand how it came to this.

Any help would be very useful

Thanks

edit retag flag offensive close merge delete

Comments

Are you missing the leading "/" in opt/ros/indigo paths as your original post indicates? This could definitely be your problem.

jarvisschultz gravatar image jarvisschultz  ( 2017-05-25 17:19:54 -0600 )edit

that's a typo here. In the file, It is correctly written. I am able to use other packages without this kind of problem.

scHoolhat gravatar image scHoolhat  ( 2017-05-30 03:30:34 -0600 )edit

I've tried placing the package in the devel folder instead and when I source devel/setup.bash, it works. How is that possible?

scHoolhat gravatar image scHoolhat  ( 2017-05-30 03:34:35 -0600 )edit