Ask Your Question
0

How to install cv_bridge?

asked 2017-05-22 19:24:38 -0500

ToughMind gravatar image

Hello everyone! I am running ros jade on Ubuntu14.04 with opencv3.2. I meet a problem with cv_bridge, as below: /usr/bin/ld: warning: libopencv_highgui.so.2.4, needed by /opt/ros/jade/lib/libcv_bridge.so, may conflict with libopencv_highgui.so.3.2 So I think I have to recompile the cv_bridge package or vison_opencv package. I have download the newest vison_opencv package, but I do not know how to use it or install it. So can anyone tell me how to do this? Thank you!

edit retag flag offensive close merge delete

3 Answers

Sort by ยป oldest newest most voted
3

answered 2017-05-24 07:53:03 -0500

vignesh gravatar image

updated 2019-08-09 03:37:14 -0500

A most simple one would be installed from the Ubuntu terminal:

sudo apt-get install ros-(ROS version name)-cv-bridge

sudo apt-get install ros-(ROS version name)-vision-opencv

It would automatically download from the Debian and installs the latest version (basically update from the old version if you already have one) in the system.

Otherwise, visit the official ROS page of that required package and download the zip file. Move the extracted package inside the catkin workspace and install it.

I hope it helps!

edit flag offensive delete link more

Comments

I have tried this. In my situation, it doesn't work. I have soled this in another way^_^

ToughMind gravatar imageToughMind ( 2017-05-24 21:52:42 -0500 )edit
0

answered 2017-05-24 21:55:59 -0500

ToughMind gravatar image

I have solved this problem by just using cmake to install the download cv_birdge package.

cmake
make
sudo make install

Then in my cmakelists, i have to add below sentence:

set(cv_bridge_DIR /usr/local/share/cv_bridge/cmake)
edit flag offensive delete link more
0

answered 2017-05-24 09:32:31 -0500

DrBot gravatar image

Rosdep update might also work. I had this issue yesterday, and

Sudo apt-get update Sudo apt-get upgrade Rosdep update

Fixed. Now can run face detect code.

edit flag offensive delete link more

Comments

Hope someone else can try this, thanks for your answer^_^

ToughMind gravatar imageToughMind ( 2017-05-24 21:59:30 -0500 )edit

Your Answer

Please start posting anonymously - your entry will be published after you log in or create a new account.

Add Answer

Question Tools

1 follower

Stats

Asked: 2017-05-22 19:24:38 -0500

Seen: 11,420 times

Last updated: Aug 09