Ask Your Question
2

robot_upstart uninstall, Job not found, nothing to remove

asked 2017-05-19 11:01:26 -0500

wuxiong2 gravatar image

updated 2017-10-07 22:40:42 -0500

130s gravatar image

Hi, All I tried to remove the auto start launch file which locates at ~/catkin_ws/src/roscopter/nodes/upstart.launch After system boot up, "rostopic list" gives a list of topics, which shows the launch file was excecuted.

I used following command to uninstall it

rosrun robot_upstart uninstall roscopter/nodes/upstart.launch

It returns

/lib/systemd/systemd
Job not found, nothing to remove

I tried

rosrun robot_upstart install roscopter/nodes/upstart.launch

it works.

I am confused and have no idea of what's the next step, anyone has ideas?

edit retag flag offensive close merge delete

1 Answer

Sort by ยป oldest newest most voted
2

answered 2017-10-07 17:24:47 -0500

dust gravatar image

I had the same problem but it seems the job name is the first part of the apparent package path so for example rosrun robot_upstart uninstall roscoptor This worked for me.

edit flag offensive delete link more

Comments

The package's document for uninstall confirms this. Format of install and uninstall being different is a bit confusing indeed.

130s gravatar image 130s  ( 2017-10-07 23:27:14 -0500 )edit

Your Answer

Please start posting anonymously - your entry will be published after you log in or create a new account.

Add Answer

Question Tools

1 follower

Stats

Asked: 2017-05-19 11:01:26 -0500

Seen: 941 times

Last updated: Oct 07 '17