holonomic_robot not honoured in base_local_planner

asked 2017-05-15 03:16:39 -0600

Sietse gravatar image

updated 2017-05-17 05:01:02 -0600

Dear list,

Starting from the fake_turtlebox example in chapter 8.2 from Ros By Example volume 1, I created a version with our own robot using a nexus robot with mecanum wheels. First without using the y-commands in the Twist-commands. This works perfectly.

After that adapted the controller to fully use the mexanum wheels, checked it by using rostopic pub commands. It now can move perfectly sideways and such.

But after setting, in base_local_planner_params.yaml, holonomic_robot to true, y_vels to [-0.3, -0.1, 0.1, 0.3], max_vel_y to 1.5, min_vel_y to 0.05, nothing seems to change.

When, in rviz, giving a new 2D nav goal there is no strafing whatsoever if the new position is just next to the current one, and a simple y-movement would suffice.

What am I doing wrong?

UPDATE: the question also is: does base_local_planner actually support holonomic robots? And whick planner does?

Thanks in advance, Sietse

edit retag flag offensive close merge delete

Comments

Did you find a solution? I am having a similar issue with a different robot. I configured it as non-holonomic but the local planner still produces strafing commands which causes my robot to do very small movement back and forward in-place.

mliefaard gravatar imagemliefaard ( 2018-10-30 11:42:34 -0600 )edit