Ask Your Question

The result of Dynamic_reconfigure tutorial not update

asked 2017-05-13 07:26:24 -0500

p.beerzzzzz gravatar image

I have studied dynamic reconfigure to use it with my project. I had followed the tutorial until . However, after I ran both and, they did not show the same results which is different to what tutorial say. The terminal that I run did not print anything and for terminal print once and not update anything. And after I ctr+C to exist the it give me these msgs which I really confuse about it.

Traceback (most recent call last):

File "/home/beerlablinux/catkin_ws/src/dynamic_tutorials/nodes/", line 15, in <module>


File "/opt/ros/kinetic/lib/python2.7/dist-packages/rospy/impl/", line 159, in wait_for_service

raise ROSInterruptException("rospy shutdown") rospy.exceptions.ROSInterruptException: rospy shutdown

I try to find out the solution in Q&A and follow this but it still be the same.

Sorry for my English and please help me.

I use ROS kinetic and Ubuntu 16.04 LTS.

edit retag flag offensive close merge delete

1 Answer

Sort by ยป oldest newest most voted

answered 2017-05-13 10:07:30 -0500

p.beerzzzzz gravatar image

I have just found the solution. In, line 14

 rospy.init_node("dynamic_tutorials", anonymous = True)

I have changed anonymous = False. And in, line 15


I have change "dynamic_tutorials" to "dynamic_tutorials/set_parameters"

Everything work!!

edit flag offensive delete link more

Your Answer

Please start posting anonymously - your entry will be published after you log in or create a new account.

Add Answer

Question Tools

1 follower


Asked: 2017-05-13 07:26:24 -0500

Seen: 43 times

Last updated: May 13 '17