ROS Resources: Documentation | Support | Discussion Forum | Index | Service Status | ros @ Robotics Stack Exchange
Ask Your Question

Problem with running urg_node with UST 20lx

asked 2017-05-09 04:59:45 -0500

Sableye96 gravatar image

I have tried running urg_node using command rosrun urg_node urg_node _ip_address:="", but it gives an error std::length_error what() : basic_string::_S_create and stops. What does this error mean and how to resolve this. Thanks for the help in advance.

edit retag flag offensive close merge delete

1 Answer

Sort by ยป oldest newest most voted

answered 2017-05-18 11:38:23 -0500

tpra gravatar image


I ran into the same problem, and I believe this is a bug in a new feature of urg_node (see my post on github: link text)

A temporary fix is to comment line number 466 in the file src/urg_node_driver.cpp:

// Before starting, update the status

Then just run catkin_make again, and it should work.

edit flag offensive delete link more


Thanks. It worked.

Sableye96 gravatar image Sableye96  ( 2017-05-19 10:41:20 -0500 )edit

This is great, thanks.

Shay gravatar image Shay  ( 2017-05-24 22:30:15 -0500 )edit

Question Tools


Asked: 2017-05-09 04:59:45 -0500

Seen: 286 times

Last updated: May 09 '17