Ask Your Question
1

How to install urdfdom on ROS indigo?

asked 2017-05-07 08:17:17 -0500

Soul Goumey gravatar image

updated 2017-05-08 08:23:00 -0500

I am following the tutorials about urdf on site this link http://wiki.ros.org/fr/urdf/Tutorials... . My ROS distro is indigo, and ubuntu distro trusty( 14.04). I created an urdf files, but i can't check it with check_urdf . I read somewhere that i need to install urdfdom before, then i downloaded urdfdom from this link https://github.com/ros/urdfdom . i placed it my catkin_ws/src. But when i compile the urdfdom package with catkin_make_isolated (because i can't compile with catkin_make), i find the following result in the terminal:

==> Processing plain cmake package: 'urdfdom' Makefile exists, skipping explicit cmake invocation... ==> make cmake_check_build_system in '/home/pi/catkin_ws/build_isolated/urdfdom/devel' -- urdfdom version 1.0.0 CMake Error at CMakeLists.txt:38 (find_package): Could not find a configuration file for package "urdfdom_headers" that is compatible with requested version "1.0".

The following configuration files were considered but not accepted:

/usr/share/urdfdom_headers/cmake/urdfdom_headers-config.cmake, version: unknown
/usr/share/urdfdom_headers/cmake/urdfdom_headers-config.cmake, version: unknown

-- Configuring incomplete, errors occurred! See also "/home/pi/catkin_ws/build_isolated/urdfdom/devel/CMakeFiles/CMakeOutput.log". make: * [cmake_check_build_system] Error 1 <== Failed to process package 'urdfdom': Command '['make', 'cmake_check_build_system']' returned non-zero exit status 2

Reproduce this error by running: ==> cd /home/pi/catkin_ws/build_isolated/urdfdom && make cmake_check_build_system

Command failed, exiting.

edit retag flag offensive close merge delete

Comments

You have not provided enough information for us to be able to help you. We need enough information to reproduce your problem to be able to help you. Please edit your question to include that information. See http://wiki.ros.org/Support fo question guidelines.

tfoote gravatar image tfoote  ( 2017-05-07 23:13:09 -0500 )edit

thank you! I added some informations in my question

Soul Goumey gravatar image Soul Goumey  ( 2017-05-08 08:19:59 -0500 )edit

1 Answer

Sort by ยป oldest newest most voted
1

answered 2017-05-08 10:28:52 -0500

This may be an easier problem to fix if you install missing packages from apt-get. You could try sudo apt-get install liburdfdom-tools which should install check_urdf into /usr/bin.

edit flag offensive delete link more

Comments

thank you for your help. I found the solution;i just missed to go in the directory before running the command.

Soul Goumey gravatar image Soul Goumey  ( 2017-05-09 07:32:13 -0500 )edit

Your Answer

Please start posting anonymously - your entry will be published after you log in or create a new account.

Add Answer

Question Tools

1 follower

Stats

Asked: 2017-05-07 08:11:49 -0500

Seen: 1,356 times

Last updated: May 08 '17