Ask Your Question
0

Is python 3.4 supported by rospy?

asked 2017-05-07 05:51:08 -0600

matansar gravatar image

Hi, I'm working now in python 2.7, but I want to use module in python 3.4. Can it cause problems if I upgrade python version?

thanks in advance

edit retag flag offensive close merge delete

1 Answer

Sort by ยป oldest newest most voted
0

answered 2018-06-15 16:56:55 -0600

tfoote gravatar image

Most of the core of ROS is tested against both Python2 and Python3. As you get to more leaf packages the level of testing is lower. If you are going to switch there are likely going to be issues that need to be debugged and preferrably submitted back upstream with a patch but there shouldn't be any major blockers.

edit flag offensive delete link more

Your Answer

Please start posting anonymously - your entry will be published after you log in or create a new account.

Add Answer

Question Tools

1 follower

Stats

Asked: 2017-05-07 05:51:08 -0600

Seen: 498 times

Last updated: Jun 15 '18