Ask Your Question
0

MoveIt! - Markers missing on custom Robot, IK-Planning not working

asked 2017-05-02 08:49:21 -0500

David_111 gravatar image

Hey there,

I've been trying to get my MoveIt-project to work similar to the pr2 demo, but I'm unable to get the markers to appear. I have seen and read, that other users had issues with this, too, and tried the suggested solutions. But none of them fixed the issue in my case. So I have tried multiple different approaches through the MoveIt setup assistant, defined the robot-arm as a chain instead of joints, set a parent group for the gripper... but no luck.

Im using the Robot lwa4p from Schunk with a very simple gripper, consisting of 3 boxes. Also: The planning of paths doesn't work at all with my robot.

Any Ideas for the cause of my problems?

(if i had >points, i would upload my xacro and a screenshot :D)

edit retag flag offensive close merge delete

1 Answer

Sort by ยป oldest newest most voted
1

answered 2017-05-02 14:13:57 -0500

hc gravatar image

updated 2017-05-02 14:14:26 -0500

One of the reasons for markers not appearing and IK not working is the IK solver not being specified. You have to specify the IK solver in the config file. This can be done manually or through the setup assistant.

Does your kinematics.yaml file have the following?

  name_of_kinematic_chain:
    kinematics_solver: kdl_kinematics_plugin/KDLKinematicsPlugin
    kinematics_solver_search_resolution: 0.05
    kinematics_solver_timeout: 1
    kinematics_solver_attempts: 10

If not you could add it. Replace the "name_of_kinematic_chain" with yours. Hope it helps!

edit flag offensive delete link more

Comments

That did solve the marker Problem! And obviously it solved the planning path not working problem :D Thanks!

David_111 gravatar image David_111  ( 2017-05-03 03:01:31 -0500 )edit

Your Answer

Please start posting anonymously - your entry will be published after you log in or create a new account.

Add Answer

Question Tools

1 follower

Stats

Asked: 2017-05-02 08:49:21 -0500

Seen: 81 times

Last updated: May 02 '17