Problem while building ros from source on RPI3

asked 2017-05-02 08:46:30 -0500

wintermute gravatar image

Hello,

Following instructions on: http://wiki.ros.org/ROSberryPi/Instal...

I tried to compile and install ros, but failed at step 3.3, namely the command:

sudo ./src/catkin/bin/catkin_make_isolated --install -DCMAKE_BUILD_TYPE=Release --install-space /opt/ros/kinetic

it will work for a while, and then give the following error I pasted below. I checked that libeigen3-dev is installed on the rpi.

Here is the error:

==> Building with env: '/opt/ros/kinetic/env.sh' ==> cmake /home/pi/ros_catkin_ws/src/geometric_shapes -DCATKIN_DEVEL_PREFIX=/home/pi/ros_catkin_ws/devel_isolated/geometric_shapes -DCMAKE_INSTALL_PREFIX=/opt/ros/kinetic -DCMAKE_BUILD_TYPE=Release -G Unix Makefiles in '/home/pi/ros_catkin_ws/build_isolated/geometric_shapes' -- Boost version: 1.55.0 -- Found the following Boost libraries: -- system -- filesystem CMake Error at CMakeLists.txt:24 (find_package): By not providing "FindEigen3.cmake" in CMAKE_MODULE_PATH this project has asked CMake to find a package configuration file provided by "Eigen3", but CMake did not find one.

Could not find a package configuration file provided by "Eigen3" with any of the following names:

Eigen3Config.cmake
eigen3-config.cmake

Add the installation prefix of "Eigen3" to CMAKE_PREFIX_PATH or set "Eigen3_DIR" to a directory containing one of the above files. If "Eigen3" provides a separate development package or SDK, be sure it has been installed.

-- Configuring incomplete, errors occurred! See also "/home/pi/ros_catkin_ws/build_isolated/geometric_shapes/CMakeFiles/CMakeOutput.log". <== Failed to process package 'geometric_shapes': Command '['/opt/ros/kinetic/env.sh', 'cmake', '/home/pi/ros_catkin_ws/src/geometric_shapes', '-DCATKIN_DEVEL_PREFIX=/home/pi/ros_catkin_ws/devel_isolated/geometric_shapes', '-DCMAKE_INSTALL_PREFIX=/opt/ros/kinetic', '-DCMAKE_BUILD_TYPE=Release', '-G', 'Unix Makefiles']' returned non-zero exit status 1

Reproduce this error by running: ==> cd /home/pi/ros_catkin_ws/build_isolated/geometric_shapes && /opt/ros/kinetic/env.sh cmake /home/pi/ros_catkin_ws/src/geometric_shapes -DCATKIN_DEVEL_PREFIX=/home/pi/ros_catkin_ws/devel_isolated/geometric_shapes -DCMAKE_INSTALL_PREFIX=/opt/ros/kinetic -DCMAKE_BUILD_TYPE=Release -G 'Unix Makefiles'

Command failed, exiting.

edit retag flag offensive close merge delete

Comments

Some answers may be here: https://github.com/ThotAlion/InstallR... not updated for kinetic yet...but gives a pre step that may be of help Also I a reasonably good success with using the Dexter microSD image from their website

rnunziata gravatar imagernunziata ( 2017-05-02 16:35:40 -0500 )edit

i will give it a try, but this one is for ros jade. the ros kinetic install above just fails because of a missing package config, named eigen3 - and i am sure it can be fixed.

wintermute gravatar imagewintermute ( 2017-05-03 00:30:09 -0500 )edit

I finally got ROS compiled and running and talking to my remote pc on my raspberrypi3 using https://github.com/ROSbots/rosbots_se... see if it helps you.

rnunziata gravatar imagernunziata ( 2017-05-06 16:56:30 -0500 )edit

Hello,

I got ros compiled and installed using only the ros_comm and not the robot install. if I generate an install file with the "robot" flag, it will still fail due to eigen.

I will test this method you mentioned as well. Do you know which packages it installs?

Cheers, C.

wintermute gravatar imagewintermute ( 2017-05-08 04:54:14 -0500 )edit

the are listed in the py file https://github.com/ROSbots/rosbots_se... you can probably modify it to your needs.

rnunziata gravatar imagernunziata ( 2017-05-08 15:00:14 -0500 )edit

yes, I found out that it failed at step 4. thank you.

wintermute gravatar imagewintermute ( 2017-05-08 15:01:55 -0500 )edit