Ask Your Question
0

Invalid <param> tag

asked 2017-04-28 07:21:24 -0600

canoe gravatar image

updated 2017-04-28 10:00:18 -0600

I am trying to modify hector_quadrotor in gazebo. because I am quite new to ROS and Gazebo while processing roslaunch hector_quadrotor_gazebo spawn_quadrotor_with_kinect.launch which exists in the original packages i failed.it shows following error:

in file: /home/ayatoshi/hector_quadrotor_tutorial/src/hector_quadrotor/hector_quadrotor_description/urdf/quadrotor_with_kinect.gazebo.xacro
while processing /home/ayatoshi/hector_quadrotor_tutorial/src/hector_quadrotor/hector_quadrotor_gazebo/launch/spawn_quadrotor.launch:
Invalid <param> tag: Cannot load command parameter [robot_description]: command [/opt/ros/kinetic/lib/xacro/xacro '/home/ayatoshi/hector_quadrotor_tutorial/src/hector_quadrotor/hector_quadrotor_description/urdf/quadrotor_with_kinect.gazebo.xacro' base_link_frame:=/base_link world_frame:=world] returned with code [2]. 
Param xml is <param command="$(find xacro)/xacro '$(arg model)' base_link_frame:=$(arg base_link_frame) world_frame:=$(arg world_frame)" name="robot_description"/>
The traceback for the exception was written to the log file

i dont know how to solve the problem Can you give me some information about how to solve the problem? thanks a lot. here is the spawn_quadrotor_with_kinect.launch:

<?xml version="1.0"?>
<launch>
   <arg name="name" default="quadrotor"/>
   <arg name="tf_prefix" default="$(optenv ROS_NAMESPACE)"/>
   <arg name="x" default="0.0"/>
   <arg name="y" default="0.0"/>
   <arg name="z" default="0.3"/>

   <arg name="use_ground_truth_for_tf" default="true"/>
   <arg name="use_ground_truth_for_control" default="true"/>
   <arg name="use_pose_estimation" if="$(arg use_ground_truth_for_control)" default="false"/>
   <arg name="use_pose_estimation" unless="$(arg use_ground_truth_for_control)" default="true"/>

   <include file="$(find hector_quadrotor_gazebo)/launch/spawn_quadrotor.launch">
     <arg name="name" default="$(arg name)"/>
     <arg name="model" value="$(find hector_quadrotor_description)/urdf/quadrotor_with_kinect.gazebo.xacro"/>
     <arg name="tf_prefix" default="$(arg tf_prefix)"/>
     <arg name="x" default="$(arg x)"/>
     <arg name="y" default="$(arg y)"/>
     <arg name="z" default="$(arg z)"/>   
     <arg name="use_ground_truth_for_tf" value="$(arg use_ground_truth_for_tf)"/>
     <arg name="use_ground_truth_for_control" value="$(arg use_ground_truth_for_control)"/>
     <arg name="use_pose_estimation" value="$(arg use_pose_estimation)"/>
   </include>

</launch>`
edit retag flag offensive close merge delete

Comments

1

Can you paste the link to the spawn_quadrotor.launch file? It would be difficult for anyone to debug your problem without access to the launch file.

lakehanne gravatar imagelakehanne ( 2017-04-28 09:16:49 -0600 )edit

I have just pasted the spawn_quadrotor_with_kinect.launch.

canoe gravatar imagecanoe ( 2017-04-28 09:52:08 -0600 )edit

1 Answer

Sort by » oldest newest most voted
0

answered 2017-04-28 09:57:50 -0600

Airuno2L gravatar image

I'm not sure why the whole file is encased in ` (backtick) marks. Try deleting those and trying again.

edit flag offensive delete link more

Comments

oh,sorry,that is a mistake when i edit the question ,the original launch doesnt have (backtick) marks.

canoe gravatar imagecanoe ( 2017-04-28 10:02:53 -0600 )edit

Hmm, it looks like it should work. Maybe it's not finding the hector_quadrotor_description package from some reason. Can you try roscd hector_quadrotor_description and see if it takes you to that package and make sure there is the file /urdf/quadrotor_with_kinect.gazebo.xacro there.

Airuno2L gravatar imageAiruno2L ( 2017-04-28 12:20:55 -0600 )edit

yeah,it takes me to the package .it is so weird.

ayatoshi@ayatoshi-K46CM:~/hector_quadrotor_tutorial$ roscd hector_quadrotor_description
ayatoshi@ayatoshi-K46CM:~/hector_quadrotor_tutorial/src/hector_quadrotor/hector_quadrotor_description$
canoe gravatar imagecanoe ( 2017-04-28 22:55:05 -0600 )edit

And the file ~/hector_quadrotor_tutorial/src/hector_quadrotor/hector_quadrotor_description/urdf/quadrotor_with_kinect.gazebo.xacro is there?

Airuno2L gravatar imageAiruno2L ( 2017-05-01 10:15:23 -0600 )edit

yes。oh i find another model with depth camera and that works。so I decide not to entangle this issue. anyway,thanks a lot for helping me。

canoe gravatar imagecanoe ( 2017-05-01 10:34:51 -0600 )edit

Your Answer

Please start posting anonymously - your entry will be published after you log in or create a new account.

Add Answer

Question Tools

1 follower

Stats

Asked: 2017-04-28 07:21:24 -0600

Seen: 563 times

Last updated: Apr 28 '17