Ask Your Question
0

About the 'time stamps' error in ROS

asked 2017-04-24 20:57:30 -0500

little_bob gravatar image

Hello,I am doing some work on ROS navigation,just at the start,and I encountered some problems.When I roslaunch the *.launch,there are a lot of erros like this:[ERROR] [1493084059.568174116]: Extrapolation Error: Lookup would require extrapolation into the future. Requested time 1493084059.049999952 but the latest data is at time 1493084059.012892115, when looking up transform from frame [odom] to frame [map].It seems that time differences exist during the program running.How can I fix this error or how can I set the time to be the same during the program?

edit retag flag offensive close merge delete

Comments

What launch files are you running? Are you using a simulator or a real robot? What simulator or robot? Is your computer's clock set accurately?

Geoff gravatar image Geoff  ( 2017-04-24 21:01:28 -0500 )edit

not a real robot,but a small car based on arduino and raspberry Pi.the name of the launch file ishongrobot_configuration.launch,this may be a launch to set the nodes.Can I upload this file?

little_bob gravatar image little_bob  ( 2017-04-25 01:12:54 -0500 )edit

If you are using hardware, then you are using a real robot. Not all robots are made by Kuka! :)

Yes, upload the launch file and the rest of your source so we can check it for problems.

Geoff gravatar image Geoff  ( 2017-04-25 01:51:51 -0500 )edit

Are you using running nodes on any computers other than the Raspberry Pi? If you are, then you need to make sure their clocks are synchronised.

Geoff gravatar image Geoff  ( 2017-04-25 01:52:42 -0500 )edit

Let's put the file aside.Sorry to forget the details:I run nodes on the raspberrypi to manipulate the arduino to controll the little car and send data of laser_scanner to a Vmware machine(Ubuntu 14.04,bridged to the physical machine) and generating maps with RVIZ.But these errors only happen on the

little_bob gravatar image little_bob  ( 2017-04-25 05:19:46 -0500 )edit

RaspberryPi's terminal and maps did exist on RVIZ,but not so correc、explicit.And the car can't be self-navigated.How can I sychronize the time of raspberrypi with the virtualmachine?I baidu and googled these things and doubt about the time.Should I change the codes or just run some commands in the

little_bob gravatar image little_bob  ( 2017-04-25 05:25:37 -0500 )edit

terminal?谢谢你的热心帮助。望回复。

little_bob gravatar image little_bob  ( 2017-04-25 05:26:05 -0500 )edit

remote refid st t when poll reach delay offset jitter

*ntp1.flashdance 193.11.166.20 2 u 32 64 377 396.120 -29.788 8.509

+ec2-34-198-99-1 192.53.103.108 2 u 42 64 277 278.546 -36.187 8.326

little_bob gravatar image little_bob  ( 2017-04-27 02:23:19 -0500 )edit

1 Answer

Sort by » oldest newest most voted
1

answered 2017-04-25 05:43:24 -0500

Geoff gravatar image

You need to set up both your Raspberry Pi and Ubuntu (running in VMWare) to use a time synchronisation service.

Ubuntu should be set up automatically, I think, but here is the documentation so you can check.

For the Raspberry Pi, it depends on which OS you have installed. Are you using Raspbian? Chrony is often mentioned as being both easy to set up and reliable on wifi connections (the original Turtlebot instructions explicitly discuss it).

edit flag offensive delete link more

Comments

really thanks

little_bob gravatar image little_bob  ( 2017-04-25 06:17:56 -0500 )edit

Hi,It's me.I found some strange things.Shall I scnchronize the system time of raspberrypi(os:Raspbian:jessie) to the Ubuntu or synchronize the ubuntu systemtime to raspberrypi?Shortly,I mean which is the time server?I install chrony on Ubuntu and did these:sudo nano /etc/chrony/chrony.conf

little_bob gravatar image little_bob  ( 2017-04-26 02:25:12 -0500 )edit

add a lineserver 192.168.0.104 minpoll 0 maxpoll 5 maxdelay .05192.168.0.104is the IP address of th Pi.Then,I restarted the chrony and ntpdate,it showed26 Apr 15:23:22 ntpdate[4922]: no servers can be used, exiting.It seems that Pi isn't the server.

little_bob gravatar image little_bob  ( 2017-04-26 02:28:01 -0500 )edit

or should I synchronize both of the two's time to the ntpserver:cn.pool.ntp.org?

little_bob gravatar image little_bob  ( 2017-04-26 02:30:45 -0500 )edit

You can sync one to the other, but you will need to set up a server on one of them and that's more trouble than it's worth in your case. Sync both of them to the same external server, such as ntp.ubuntu.com.

Geoff gravatar image Geoff  ( 2017-04-26 02:33:39 -0500 )edit

Raspbian Jessie apparently also has NTP time sync working out of the box. Does your Raspberry Pi have Internet access?

Geoff gravatar image Geoff  ( 2017-04-26 02:35:21 -0500 )edit

yes,with Wifi to the Internet

little_bob gravatar image little_bob  ( 2017-04-26 02:48:21 -0500 )edit

Please post the output of ntpq -p on both computers.

Geoff gravatar image Geoff  ( 2017-04-26 02:49:52 -0500 )edit

Your Answer

Please start posting anonymously - your entry will be published after you log in or create a new account.

Add Answer

Question Tools

2 followers

Stats

Asked: 2017-04-24 20:57:30 -0500

Seen: 401 times

Last updated: Apr 25 '17